1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Trailer lighting question

Discussion in 'Strobe Lighting' started by cameo89, Sep 7, 2011.

  1. cameo89

    cameo89 Senior Member
    Messages: 669

    First off I know it's not strobe lighting but a safety lighting question.
    My 1/2 chevy truck and 20' trailer has NO brake lights only when I have my running lights and or headlights on, it shuts off my running lights when I depress the brake pedal, but if I shut off all running lights my brake lights work perfect.

    This only effects the trailer lighting.

    I just noticed this morning, so I havent checked all my grounds yet.

    Thanks in advance.

    Messages: 79

    Sounds as if a bad trailer ground.
    Do your turn signals work ?
    Turn and brake lights are same wire and element in the bulb.
  3. cameo89

    cameo89 Senior Member
    Messages: 669

    Yes both turn signals and hazzards work and brake lights work when all running lights are OFF, if my running lights are on as soon as I depress brake pedal running lights shut off, but I just noticed that all my other side lights stay on. I have a feeling its a bad ground, I will have to look at it this evening after work.
  4. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,990

    Definitely a grounding issue. If it does not effect the side markers it would be in the rear light fixtures themselves rather then a main trailer ground
  5. cameo89

    cameo89 Senior Member
    Messages: 669

    Well I got all my trailer lights fixed, it was a bad or lack of ground, my wiring is 4 wire all the way back to the lights, and thats where I grounded it, I guess it was to far, now I have it grounded about 2' from the plug and every light is brighter now.

    Thanks for your suggestions:salute:

    Messages: 79

    glad to hear that you got it fixed