1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Trailer brake problem

Discussion in 'Chevy Trucks' started by QuadRacer041, Sep 23, 2016.

  1. QuadRacer041

    QuadRacer041 Senior Member
    Messages: 140

    I'm having a problem with the brakes on my trailer not working. I've done some testing and seems the problem is intermittent and seems to be on the truck side.
    The truck is a 09 3500hd chevy gas. With factory installed brake controller.
    When i engage the slider to full brake power, i intermittently get power to the blue wire on the trailer side and also can here the magnets humming. Some times i ding will go off in the truck then it says either service trailer brake system or check trailer wiring. All the fuse in the cab and under the hood are fine.
    Any ideas where to look?
  2. fireside

    fireside Senior Member
    Messages: 657

    Check the fuse block under the hood. They burn out or get corrosion causing the problem. You should be able to pull it apart to clean connection
  3. Randall Ave

    Randall Ave PlowSite.com Addict
    Messages: 1,420

    If it's intermittent only on the trailer side, look at you plug contacts. Mabey install new plug and receptical. Try that. A good clean ground is very important.
    FredG likes this.
  4. kimber750

    kimber750 PlowSite Veteran
    Messages: 3,165

    Do the brake wires run through the axle of trailer. Very common place for wires to rub thru since they just rattle around inside the axle tube.
  5. QuadRacer041

    QuadRacer041 Senior Member
    Messages: 140

    I'm thinking this may be the issue, any thoughts?