1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Toro Powerclear Problem Starting.

Discussion in 'Truck & Equipment Repair' started by locallawncare.c, Mar 20, 2013.

  1. locallawncare.c

    locallawncare.c Member
    Messages: 78

    I have a Toro Powerclear 2-stroke, I do residential driveways and I find that sometimes it won't start again after just using it 3 minutes prior, my house are close by. It starts fine when cold, with the choke & 2 pumps, when hot I usually never have to choke or prime it, but sometimes it just won't start. Recently I have been letting it run for 1 minute after use to cool down and I think it helps, anyone else have this problem?
     
  2. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,951

    either fuel or spark related.
    if it was me,,,id be leaning towards coil
     
  3. WIPensFan

    WIPensFan PlowSite Veteran
    Messages: 3,487

    You can't prime those when they have been running. If that's what you're doing, that's why it won't start again.
     
  4. locallawncare.c

    locallawncare.c Member
    Messages: 78

    I'm not priming or choking once its been running, I feel like it has to do with letting it cool down after use, I find if I leave it running for a minute while I finish shoveling it helps, but I'm not sure it thats the cause for sure or not. I only a couple years old and this is the first year of real heavy use.
     
  5. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,951

    Like I said either fuel or spark. Get a spark tester. When it acts up,,,put the tester on it and give it a pull. If the spark is good and bright then its fuel related.