1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

the mother of all plow problems

Discussion in 'Fisher Engineering Discussion' started by dmark, Dec 31, 2015.

  1. dmark

    dmark Junior Member
    Messages: 5

    I have a fisher ez v 14 pin 3 plug module plow on a 2006 f350 if I plug the truck into a different plow all functions work fine so bear in mind problem is on plow side, here goes.......left button makes it go up down only trips s1 valve not s1 and s3, up and right button spin pump with no valves activating...... here's the kicker, none of the wing buttons even trip the motor solenoid, if I power the valves at the plow harness and ground them individually they all work........again truck side should be fine as it works on a different plow,it has a new 3 port isolation module and a new 9 button controller, all the plow wiring seems to be functioning..........but the plow just won't work......any suggestions?
     
  2. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,976

    So as a quick thought. If you tried your truck with another plow and it worked. What about the plow with another truck and Ser what happens?
     
  3. dmark

    dmark Junior Member
    Messages: 5

    Do not have another truck it was out of town tonight not availible
     
  4. dmark

    dmark Junior Member
    Messages: 5

    But I would safely assume if truck works 100% fine with a different plow it's on the plow side......or my truck and plow got a divorce this summer and I missed a notice about it
     
  5. chevyzrule810

    chevyzrule810 PlowSite.com Addict
    Messages: 1,239

    So are you testing from the plow harness forward?.Have you opened up the plastic cover on the solenoids to make sure they are all ok?If your truck works with another plow I would say it could be the plow harness itself somewhere?
     
  6. dmark

    dmark Junior Member
    Messages: 5

    All coils and valves are good, harness on plow is good, plugs are clean, the things that I'm confused on are these, the controller isn't sendin signal to proper coil according to wiring diagram but yet it still works on a different plow, and the fact the wing buttons do not even trip the relay on the plow for my truck bug they work fine with a different plow
     
  7. chevyzrule810

    chevyzrule810 PlowSite.com Addict
    Messages: 1,239

    Different v-plow? Do have a different truck to test the plow with?
     
  8. dmark

    dmark Junior Member
    Messages: 5

    Problem solved even though the coils tested from the plug on the plow through the harness the plug internally must have somehow been shorting out when plugged in new Plow Harness and it works fine.
     
  9. leigh

    leigh PlowSite.com Addict
    from CT
    Messages: 1,997

    Good deal! I hate reading about these troubles,afraid it will be me next,gotta love the help here!
     
  10. peteo1

    peteo1 PlowSite.com Addict
    Messages: 1,660

    I actually enjoy these threads more than a lot of the others. I dont like seeing people broke down or having issues but when it's my turn to have problems this site has a ton of knowledge posted. Usually I can get rolling again with a quick search if I can't figure it out on my own
     
  11. chevyzrule810

    chevyzrule810 PlowSite.com Addict
    Messages: 1,239

    I figured it was.If your truck works with another plow then it's not the truck that's the problem,it's the plow itself.Thats why I asked if you had tested the plow with another truck.Glad you got it fixed