1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

The Boss Plow

Discussion in 'Boss Plows Discussion' started by maritj, Jan 17, 2009.

  1. maritj

    maritj Junior Member
    Messages: 4

    I have a Boss plow and while using it it quit functioning (raise, lower, right, left). When I push the controls it makes a clicking noise at the solenoid under the hood, but no action on the plow?
     
  2. Camden

    Camden PlowSite Fanatic
    Messages: 6,598

    I had the exact same problem yesterday. I sent a message to a guy who knows more about plows than I do and this was his response:

    >>Change the under hood solenoid (especially if your unsure on the age of it) and most importantly spread the pins and clean the sockets in the power connector at the bumper. That should fix it.

    Power cable connectors are well known to cause that very issue when they get aged. If you want to test it, the next time it does it again...jump out and wiggle the power cable connector. I'll bet money it'll instantly begin to work again.<<
     
  3. Indy

    Indy Senior Member
    Messages: 704

    Take the power cable loose (at the plug, black and red) and take a small screw driver and open the ends of the connectors so they make better contact (should be one male end on each side).

    That could likely be it, or you may have a bad ground.

    Keep us posted
     
  4. maritj

    maritj Junior Member
    Messages: 4

    did you have power to your lights, but no functionality to your plow? It seems to me that the juice isn't getting to the motor. Did you get the clicking noise? Thanks again for all your help!