1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

TBI off idle stumble

Discussion in 'Chevy Trucks' started by jimz2500, Jan 26, 2009.

  1. jimz2500

    jimz2500 Member
    Messages: 42

    Hey evryone.
    My 94 tbi 350 has developed a speratic off idle stumble.
    And the injectors are noisey....also intermitent.
    AND sometimes it starts hard, like the timing is to far advanced.
    12psi reading for fuel verified with gauge.
    Newer fuel pump,strainer, filter.
    Newer tune up, plugs ,wires,cao, rotor, control module and coil.
    Timing is Aok, verified with a lite and tan wire unhooked.
    No CEL.

    Any input would be great.
    Thanks in advance.
  2. Mebes

    Mebes Senior Member
    Messages: 386

    Disconnect the vacuum line at the fuel pressure regulator and see if the fuel pressure goes up (Engine running at idle).
    Did you look at the fuel spray with the air cleaner open. (engine running at idle)
    Does the system hold pressure with engine off. (Cycle the key from run>off>run>off without starting engine)

    Any codes?
    Is the problem only when cold, or when warm, or both?

    My first impression would be fuel pressure regulator,.
    But a couple of other places I would check next would be. (in order)
    1 Vacuum leak
    2 Throttle position sensor.
    3 Manifold air pressure sensor (MAP)

    Don't start throwing parts at it yet.
    I have not worked on one of these systems in about 10 years.
    These are just a couple of things that I would be looking at first.

    Someone may see this post and know exactly what the problem is.

    Good luck
  3. jimz2500

    jimz2500 Member
    Messages: 42

    Thanks for the write up S, I am going to check on those things today seeing as its going to snow..

    I will keep you all posted.
  4. 2COR517

    2COR517 PlowSite Fanatic
    Messages: 7,115

    Apparently the TBI to manifold gasket can be a problem with those. Spray some carb cleaner around it when it is running and see if it revs up a little.
  5. jimz2500

    jimz2500 Member
    Messages: 42

    the truck is fixed

    after checking and testing the basics.....

    found that the base timing was off, like way off


    bad pick up coil...replaced, retimed, good to go.

    the pic up coil some how advanced the timing during the crank and run cycle, which it should not.

    At least I verified alot of parts were still good....lol.

    Thanks for the help!!
  6. 2COR517

    2COR517 PlowSite Fanatic
    Messages: 7,115

    Thanks for letting us know!