1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Tach Issues

Discussion in 'Truck & Equipment Repair' started by xgiovannix12, Apr 28, 2014.

  1. xgiovannix12

    xgiovannix12 PlowSite.com Addict
    Messages: 1,419

    I installed a tach awhile back on my 92 k1500. Sadly the tach stopped working.
    When I started to diagnose the issue I noticed I was getting 13 volts coming from the tach wire and I doubt thats normal. Just wondering if my ICM is not doing the correct job. Thanks

    going to be playing around with it more tomorrow.
     
  2. kimber750

    kimber750 PlowSite Veteran
    Messages: 3,611

    Not sure about the order GM's but the newer ones are known for servo motor issues. There is an used to some place you can send the cluster to have it repaired. Can't think of the name. Mine got repaired under warranty.
     
  3. xgiovannix12

    xgiovannix12 PlowSite.com Addict
    Messages: 1,419

    this aint a stock tach its aftermarket. I tried 3 different tachs still no reading. IM kinda confused with the 12 volts at the single wire coming from the coil
     
  4. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,946

    12v at the coil sounds right. So what's the issue with that?
     
  5. xgiovannix12

    xgiovannix12 PlowSite.com Addict
    Messages: 1,419

    on the red wire Not the white.
     
  6. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,946

    At the coil. Usually its pwr in and signal gnd usually how it works.
     
  7. leolkfrm

    leolkfrm PlowSite.com Addict
    Messages: 1,403

    tach is off the dizzy, the 2nd terminal next to the power
     
  8. kimber750

    kimber750 PlowSite Veteran
    Messages: 3,611

    Basic hookup of tach signal wire goes to neg side of coil. Then there should be a switch on back of tach for number of cylinders.
     
  9. xgiovannix12

    xgiovannix12 PlowSite.com Addict
    Messages: 1,419

    got it to work. The switch is on 8 cylinder but its reading incorrectly. I Did notice my ground strap from the engine to the body broke maybe this is whats causing it...
     
  10. leolkfrm

    leolkfrm PlowSite.com Addict
    Messages: 1,403

    gm hei have a plug in on the cap off the module that works depending on tach...it is the oem hookup