1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Swenson vbox problem?

Discussion in 'Ice Management' started by Showmestaterida, Feb 10, 2010.

  1. Showmestaterida

    Showmestaterida Senior Member
    Messages: 408

    Has done this since it was new . Never really bothered me but now it does. Have the plastic cover back as far as it can go without rubbing on the chain. Is it normal or what? Any suggestions? Thanks

    DSC00507.jpg

    DSC00508.jpg

    DSC00510.jpg

    DSC00511.jpg

    DSC00507.jpg

    DSC00508.jpg

    DSC00510.jpg

    DSC00511.jpg
     
  2. snobgone

    snobgone Senior Member
    from CT
    Messages: 122

    Are you asking about the excess salt?
     
  3. Showmestaterida

    Showmestaterida Senior Member
    Messages: 408

  4. JD Dave

    JD Dave PlowSite Fanatic
    Messages: 11,046

    Normal, we bolt rubber on the side of ours and then made a pan to hold ours in and it works very well. We also put stainless under ours so it doesn't drop on the frame of our cab and chassis. This is the 10th season we've used it that way and it's worked great.
     
  5. JohnnyRoyale

    JohnnyRoyale 2000 Club Member
    Messages: 2,935

    They all do that. By the looks of it you have the salter mounted directly on the flatbed. You should consider mounting them on 6x6 PT, so you can wash the salt out from under it.
     
  6. BuffaloJoe

    BuffaloJoe Member
    Messages: 51

    Try tightening the conveyor chain. If its loose it will drag the salt under the unit and collect in the front. Also as mentioned above, mount it on some blocks.
     
  7. JD Dave

    JD Dave PlowSite Fanatic
    Messages: 11,046

    It will do it no matter how tight the chain is. Also I've run into more problems having my chain too tight them too loose. JMO Personally who cares about the salt under it.
     
  8. Showmestaterida

    Showmestaterida Senior Member
    Messages: 408

    I thought the chain might have something to do with it. Its a little loose so will tighten. Any pix of the spreader on blocks setup. Manual says to sit flat on bed supported by the longitudinals/sides. Do not support sreader by the body jacks alone . Is the ss piece removable under the spreader? How do you wash it out if not? Had it raised when I first bought it but salt was slowing coming out bottom , needed a piece of ss under it like JD said. Any pix of your setup? Thanks
     
  9. cretebaby

    cretebaby PlowSite Veteran
    Messages: 4,162

    You need to add a little broom above the return chain to clean the chain off.
     
  10. Shadetree Ltd.

    Shadetree Ltd. Junior Member
    Messages: 29

    you DO NOT need to put in on blocks, the swenson ss have a formed bottom that is solid. The only place that salt accumulates is where you took a picture. Part of the reason for the buildup is because the salt isn't building up underneath the spreader in/on the truck bed. We just rinse it out after a storm.
     
  11. Jay brown

    Jay brown PlowSite.com Addict
    Messages: 1,783

    we have a commercial model swenson and it has a rubber flap that cleans off the top side of the chain and flicks the salt into the drop chute. i looked into doing this with our little swenson like yours and it would be tough to retrofit because the small spreaders are more of a closed system whereas the big ones are open and have room to work on them. ps. do not tighten the chain to fix this proplem all it will do is tighten the chain.