1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Suburbnite Driver's Side light not working

Discussion in 'Western Plows Discussion' started by jeffwoj, Feb 26, 2013.

  1. jeffwoj

    jeffwoj Junior Member
    from SAGINAW
    Messages: 5

    I have a 7' 4" suburbinite plow hooked up to my 2003 Chevy 1500. The lights have been working all season. I put HIDs on my truck and I went to hook up to my plow and the driver's side plow low beam did not work, but the highs did. I tried to trouble shoot the problem. I unplugged the light harness and my truck head lights low/high beams work. I unhooked the HIDs and put the regular bulbs back in and plugged the harness back in. The driver's side plow light still did not work. I changed the bulb and no change. I am just starting to work on my own plow. If anyone can help I would greatly appreciate it.
     
  2. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,965

    Assuming its a ultramout plow.
    You might have reversed the light plug on the plowside harness from A to B. Or vise verses
     
  3. jeffwoj

    jeffwoj Junior Member
    from SAGINAW
    Messages: 5

    Thank you Dieselss, would I have to switch the ports around to correct the issue?
     
  4. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,965

    Just at the "plow" side truck harness. Where the harness connects to your tk....should be able to flip the connector. It's a non.directional plug
     
  5. jeffwoj

    jeffwoj Junior Member
    from SAGINAW
    Messages: 5

    All my plugs are directional..... it might not be the uni mount
     
  6. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,965

    Ok? Do you have a big box or relays for the plow lights ?
     
  7. jeffwoj

    jeffwoj Junior Member
    from SAGINAW
    Messages: 5

    I have a isolation module 3-port
     
  8. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,965

    Ok. Then ck the headlight plugs
     
  9. jeffwoj

    jeffwoj Junior Member
    from SAGINAW
    Messages: 5

    Okay, I also have to go through all the wires. I might've unhooked a wire when I was installing the hids