1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

stupid stobe lights!

Discussion in 'Strobe Lighting' started by tjctransport, Feb 23, 2014.

  1. tjctransport

    tjctransport PlowSite.com Addict
    Messages: 1,390

    it took me 3 1/2 hours of truoble shooting today to fix the strobes in my 02.
    they went out 2 snows ago. i finally had the time today to work on it.
    pulled the passenger seat to access the power head, and pulled the optimax box out. put a good used whelen 660 in. still not strobes.
    went back into the garage, and got a good used whelen 604 box.
    still dont work, so i pull a 4 head box out of the crown vic that i know works, i even tested it before pulling it.
    put it in the truck and still nothing. what the heck???
    so i pull a strobe out of the crown vic.
    pull all wires out of the box and plug the crown vic light in. it works.
    start plugging in truck lights and they all work?
    put the truck back together and go to close the tailgate, and hear sparking.

    the driver side rear power wire shorted out against the truck body, shutting the box down.

    3 1/2 hours of trouble shooting for a stupid shorted out wire.
  2. Strobesnmore

    Strobesnmore Senior Member
    Messages: 411

    That's usually what it ends up being. Strobe power supplies rarely fail.
  3. tjctransport

    tjctransport PlowSite.com Addict
    Messages: 1,390

    yea, i should have just went to the bulbs in the first place. i have been running strobes in one way or another for 25 years now, and not once has a box totally failed.