1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

stumped any help is apressicated??

Discussion in 'Western Plows Discussion' started by FordF350Diesel, Dec 3, 2009.

  1. FordF350Diesel

    FordF350Diesel Junior Member
    from Ill
    Messages: 9

    i have a unimount and did lift ram packing, new motor, new filter and, selnoid. and it was still runing slow so pulld it apart and filter was very clogged so i cleaned it, and when i turn the shaft on the pump it spins ok and counterclockwise it kinda spins rachet like but after i took it out and cleand it its fine but it toghter and it ran very normal for about 4 lifts then got slow. left and right its fast but up and down isnt close to being rite. pulled it apart again filter was clean and pump spins the same. put it bck together and still left and right fast, up slow any ideas im going crazy bout this damn thing
  2. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    If it plugged the filter with only four cycles then I'd be pulling the valves, poppet's and quill from the valve block and clean them as well as the block. Sounds like it has some debris floating around from the new packing's (not uncommon) causing restrictions.

    A can of brake clean, the shop manual for the pump, and compressed air is your friend now. :nod: