1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

stuck in left !! Help !!

Discussion in 'Truck & Equipment Repair' started by yingyang860, Nov 18, 2006.

  1. yingyang860

    yingyang860 Junior Member
    Messages: 3

    :confused: I need some advice, Meyer 47 stuck to the left. motor runs, up & down fine !
    when this happened I angeled to the left then went right and blade went more left now it is stuck in the left . crossover valve ?? Help !!
     
  2. ght1098

    ght1098 Member
    Messages: 86

    Could be a bad coupler, happened to me, gave me fits trying to figure it out.
     
  3. fernalddude

    fernalddude PlowSite.com Addict
    Messages: 1,105

  4. starc

    starc Senior Member
    Messages: 229

    Had the problem once with an old meyers plow. Turns out the stop broke off that limits the plow from turning to far. I just pulled the truck up to a curb and place the right side of the blade against the curb, slowly going forward while trying to turn the blade back toward the right. Now with the blade working again...repaired the stop and all was good.

    I've also had problems with the of the plug-in hose connectors...quick fix on site was to remove the connectors and knock the centers out of the faulty connector so I could Finnish working and replace it later.
     
  5. imdawrlus

    imdawrlus Member
    Messages: 71

    i say check thoes quick couplers
     
  6. StorksAuto

    StorksAuto Senior Member
    Messages: 186

    See if you are getting magnitism out of the green coil. See if the valve is clicking? In most cases it is the valve. It is the coil and valve closest to the couplers in the angling block
     
  7. yingyang860

    yingyang860 Junior Member
    Messages: 3

    :nod: THANKS FOR THE HELP GUYS !!:waving:
     
  8. fernalddude

    fernalddude PlowSite.com Addict
    Messages: 1,105

    Did you fix it ?
     
  9. Robhollar

    Robhollar Senior Member
    Messages: 766

    Bad coupler.Change both of them...Rob
     
  10. jcesar

    jcesar Senior Member
    from Mi
    Messages: 492

    shoot it. Or get a big fu%&in hammer!!!!
    Just kidding.
    Did you check your electrical connections?