1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

strange vibration 04 ram

Discussion in 'Ram Trucks' started by elite1msmith, Oct 27, 2010.

  1. elite1msmith

    elite1msmith 2000 Club Member
    from chicago
    Messages: 2,762

    04 ram 2500 4x4 5.9 L gas hemi 140k miles western 8 footer 1 year old

    a few weeks ago i noticed a slight sqeeking noise while driving slowly...i figured it was a u joint - went under the truck, gave it a shake down, didnt find anything

    drove it the last few days and i notice a vibration , which seems to be getting more noticable, only occurs under acceleration, and only in 2wd. does not change while turing. braking, coasting, 2 or 4wd doesnt occur...only while acceleating and in 2 wd. at first i thought maybe the tires need balancing, but since it doesnt do it while coasting (it also seems to be a "faster vibration" than the tire spin..dont think that is it. i never had a u joint cause a vibration on me...only a clunck or a sqeecking noise....and like i said i didnt see anything wrong with the u joints (not that i pulled it down and apart thou)

    i heard the rear ends were bad on these trucks? any help or advice? how about balancing the drive shaft? again another path i have never been down. just stange that it stops in 4 wd

    as best i can tell its coming from the rear of the truck, but the steering wheel does shake too
     
  2. sno commander

    sno commander PlowSite.com Addict
    from ct
    Messages: 1,061

    id guess rear u joints. might as well start replacing them one less thing to worry about with 140k. is this a regular cab or quad cab longbed with a 2 piece rear drive shaft?
     
  3. elite1msmith

    elite1msmith 2000 Club Member
    from chicago
    Messages: 2,762

    Quad, short bed. 1 peace shaft
     
  4. elite1msmith

    elite1msmith 2000 Club Member
    from chicago
    Messages: 2,762

    Is a slight vibration normal when they go bad? I just never had that before.
     
  5. USMCMP5811

    USMCMP5811 Senior Member
    Messages: 267

    If it's in the rear, I'd say U-joints. The squeek troubles me though... Have you checked your hub bearings?????
     
  6. elite1msmith

    elite1msmith 2000 Club Member
    from chicago
    Messages: 2,762

    The squeak went away, no have not checked the hub bearings,
     
  7. USMCMP5811

    USMCMP5811 Senior Member
    Messages: 267

    the squeak can sometimes be indicative of a hub bearing starting to go south. last one i had go on me, 3 days after hearing the squeak, the hub was trying to pull it self apart....
     
  8. DHDB

    DHDB Member
    Messages: 94

    Only squeaks under acceleration, sounds kind of like plastic? U-Joints stiffened up. Had the same annoying problem here last year. The stock u-joints have some sort of teflon covering. Replaced them and no problems since.
     
  9. TPC Services

    TPC Services Senior Member
    Messages: 875

    it's sounds like what both of my new trucks have done with less then 40k on them, it may be your rear drive shaft's u joint.
     
  10. huskerfan523

    huskerfan523 Member
    Messages: 51

    just replaced mine a month or 2 ago. same truck, but only 45k. same symptoms; started with a sqeak, followed by vibration, only on accel, never any other time. 1 ujoint hosed. had same concerns you did, but it was easy enough to fix.