1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Strange 2002 F350xl headlight Problem

Discussion in 'Ford Trucks' started by Jgramlich, Nov 17, 2012.

  1. Jgramlich

    Jgramlich Senior Member
    Messages: 111

    When I turn my headlights on, they don't turn off. I put the switch in the off position, and my parking lights stay on. If it's any help, my high beam switch doesnt work either (i can flash them, can't keep them on).

    I've been disconnecting the battery after i turn the truck off, and when i reconnect they stay off. I can drive with my running lights, they turn off fine.

    Went through the fuse box all is well.

    Any ideas? Bad switch?
     
  2. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,972

    I would say headlight switch
     
  3. smoore45

    smoore45 Senior Member
    Messages: 526

    Sounds like it could be a stuck relay too, since you said the lights dont come on after disconnecting the battery (which de-energizes the relay). Could also explain the brights if they are part of same relay.
     
  4. tjctransport

    tjctransport PlowSite.com Addict
    Messages: 1,390

    first thing you should do is change the multi function switch.
    that alone may just fix your problems.
     
  5. metro25

    metro25 Junior Member
    from 48858
    Messages: 10

    Pull fuse 4 in the battery junction box and see if the park lamps work normally (on/off with the headlight switch.) If they do operate normally with fuse 4 out, check for a short in the trailer wiring running lamps, most likely at the trailer connector harness or near it.
     
  6. MR. Elite

    MR. Elite Senior Member
    from E Town
    Messages: 549

    have U checked the back of the switch at all...? seen many that get way hot and melt to the point the functions r all confused!! or as was said earlier... next would b relay, it very likely that its stuck in the on position until power shut down