1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Storm coming tonight ... need help, plow lights dont work!!

Discussion in 'Fisher Engineering Discussion' started by 20Silverado05, Dec 29, 2008.

  1. 20Silverado05

    20Silverado05 Senior Member
    Messages: 465

    The other day i was driving around and my plow lights just turned off and the headlights to my truck came on everything was working fine and then stopped. I dont know if there are fuses for the headlights or anything but if i dont get them to work im screwed for this storm or im gunna have to drive with the plow low so my truck headlights clear. Any help would be greatly appreciated . Thanks
    (This is the plow and truck if it helps.)
    [​IMG]
     
  2. mycirus

    mycirus Senior Member
    from Mass
    Messages: 589

    I love your truck. I know that doesnt help you but as far as your question, I have no clue.
     
  3. bad93blaster

    bad93blaster Member
    Messages: 62

    just the lights stoped working or did everything?
    there should be a fuse that runs everything
    how are the plugs up front are the pins green?

    i heard mostly rain 4 tonight
     
  4. 20Silverado05

    20Silverado05 Senior Member
    Messages: 465

    Everything is fixed now. Replaced the isolation module with one i had laying around my garage and it did nothing and then i checked my fuses all were fine until i found one they hid under my strobe wires and there were 2 10 amp fuses and 1 was out, replaced it and everything is better. Thanks for the help tho
     
  5. searay220

    searay220 Member
    Messages: 99

    Was the fuse you replaced one of the two fuses that are built into the harness?
     
  6. 20Silverado05

    20Silverado05 Senior Member
    Messages: 465

    Yes I think so they were off the wiiring harness but under a bunch of other wires, didnt see them in the beginning..