1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

still leaking

Discussion in 'Meyer / Diamond Products Discussion' started by ned5485, Mar 14, 2007.

  1. ned5485

    ned5485 Member
    Messages: 36

    B&B has been most very helpful with all my issues, but in case someone else has an idea here is my problem;
    My E-47 is leaking(more like pouring) fluid out of the little hole below the motor and above the pump. As suggested, I have replaced the pump shaft seal. It looked like the rubber had blown out. So i was positive that my troubles were over. I just finished putting it back onto the jeep. I had it go up without leaking. And then tried to turn right, and it starting pouring out of that little hole. And now it pours out when I go up too.

    I did not have plow mounted, so I did not have the hoses hooked up either. But, that should not matter. Should it? Did I possibly just not get the seal down onto the shaft far enough? Is there another potential problem? I don't know what to do, except for ordering another seal, and trying again.
     
  2. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    PM sent.:)
     
  3. lawnmedic

    lawnmedic Senior Member
    Messages: 703

    Relief valve stuck....:)