1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Still having gas gauge issues.

Discussion in 'Chevy Trucks' started by LB Landscaping, Oct 24, 2005.

  1. LB Landscaping

    LB Landscaping Senior Member
    from Maine
    Messages: 324

    Anyone having issues with the gas gauge on their 1 tons? I have an 03 and have been having problems with it since I got it. My dealer cannt fix it, its driving me nuts!!!! Gauge always always reads empty and half the time the back tank doesn't pump to the front.:realmad: :realmad: :realmad:
     
  2. lawnmedic

    lawnmedic Senior Member
    Messages: 703

    the sending unit needs to be replaced to correct the gauge problem. This is a common problem. This is an easy fix if it's a dump, a lot harder if it has a fixed bed...
     
  3. LB Landscaping

    LB Landscaping Senior Member
    from Maine
    Messages: 324

    Its a dump but I've had the sending unit replaced about 5 times and it still does it. They gave me all kinds of lame excuses like don't fill the tanks while the truck is running, don't park or idle on a hill (I live in Maine, everythings a hill).
     
  4. davidrbean

    davidrbean Member
    Messages: 49

    Try this or see if its been done
     

    Attached Files:

  5. davidrbean

    davidrbean Member
    Messages: 49

    Here are the pics that go with it

    113378375.gif

    113378379.gif

    113378380.gif

    113378381.gif

    113378382.gif
     
  6. LB Landscaping

    LB Landscaping Senior Member
    from Maine
    Messages: 324

    Thanks a bunch, I am going to print his off and bring it to my dealer.