1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

sticking valve??

Discussion in 'Blizzard Plows Discussion' started by alsam116, Jan 9, 2010.

  1. alsam116

    alsam116 Senior Member
    Messages: 217

    Hey guys i have a 8 foot straight and sometimes the plow sticks to the left angle. Even when im trying to get it back straight or to the right it stays left but the motor is running i can hear it whining. it did this some last year and i get out and pull it while the old lady is holding the joystick then it moves but now it isnt moving when i pull on it at all, unless i drive it into a concrete post or something to get it to move but then if i drop the plow then raise it it goes up and to the left at the same time. could this just be a valve ot the coil...OR BIGGER problem??

    Thanks in advance,
    alex
     
  2. beam

    beam Senior Member
    from pa
    Messages: 314

    sounds like the screen in the valve is stuck take out valve and remove any garbage found
     
  3. alsam116

    alsam116 Senior Member
    Messages: 217

    ok where is the screen?? is it in the valve or the in the maifold? thanks for the response i will get to it today even though there is no accumulating snow for atleast a week or so, better to be prepared..Thanks again
     
  4. beam

    beam Senior Member
    from pa
    Messages: 314

    on the valve
     
  5. alsam116

    alsam116 Senior Member
    Messages: 217

    thank you, problem solved there was a sliver of plastic keeping the valve stuck open...all better now everything works as should... now al we need is a good month of snow HEHE
     
  6. alsam116

    alsam116 Senior Member
    Messages: 217

    UPDATE i am still getting stuff stuck in the valve i can use the angles about 5-10 times each way and then the S3 valve getsthe shreddings in the screen again. I need help guys. i was told by 2 people that the lines were corroding from the inside so i had new lines made. put the new lines on the plow and i am still getting small chunks stuck in the valve. i am so damn aggrevated i want to just take the damn thing to the dealer and tell them do whatever is needed to fix it(but dont have enough $$$ for that). also i cant lower the plow with the power hitch or by the controller so i also need suggestions for that as well, i checked all of the coils ( S5,S6, S8) and they are all good. when i adjust the FCV it lowers by itself wen raised but quickly and when i adjust the FCV to make it drop slower it wont even drop an inch. Sorry for the long post guys but im getting fed up with this. if you have any Q's just ask.
    i thank you guys in advance,
    Alex
     
  7. lilweeds

    lilweeds PlowSite.com Addict
    Messages: 1,178

    Angle cylinders are probably torn up from over extending.
     
  8. fireside

    fireside Senior Member
    Messages: 661

    I feel your pain i'm going thru the same thing but i can'nt get my power latch to work at all. Best of luck i'm still working on mine. At one point i had nothing working.
     
  9. alsam116

    alsam116 Senior Member
    Messages: 217

    the problem is fixed...the seals in the angle rams were DESTROYED from (driver side angling to far and the ram hit the kick stand mount) and tha passenger side was at no fault of mine, the seal was destroyed due to the "holder" being to sharp and shreading it a little at a time. the dealer replaced the passenger ram under warranty(jusst bought in sept) and i had to flip the bill for the driver side $299!!! just in sept when i bought the passenger side ram it was only $160ish. how the hell can they double in price that quick. i asked him and he said they all came in at the same time so he didnt know why the ram in september was so much cheaper. and i fixed the reason it wouldnt go down is because the S5 VALVE was stuck so it wouldnt let fluid pass through to drop the plow. i thought it was a bad coil so i bought a S5 coil 2 weeks ago for $50 and that didnt work so now i have a spare. i hope these posts help other guys out because i know when i have a question i come on here and ask.
    Thanks to everyone who has responded to my Q's,
    Alex

    foregot to mention it ended up costing me about $500 in oil,valve,coil, and labor to the dealer to fix my problem soooo let it snow, they are calling for 4-6 so bring it so i can recoupe some of my lost$$$$
     
    Last edited: Feb 5, 2010