1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

solenoid clicks but motor does not run..?

Discussion in 'Truck & Equipment Repair' started by LILsnowblazer, Jan 2, 2010.

  1. LILsnowblazer

    LILsnowblazer Junior Member
    Messages: 14

    When I hit the switch on my controler the solenoid clicks but the motor on my meyer e47 does not receive power...is the solenoid bad?
     
  2. no lead

    no lead PlowSite.com Addict
    Messages: 1,308

    probably bad connection. take a pair of jumper cables and go from the battery + - to the motor power stud and the motor case. if the motor won't run, its bad.
     
  3. LILsnowblazer

    LILsnowblazer Junior Member
    Messages: 14

    The motor runs when I do that.
     
  4. no lead

    no lead PlowSite.com Addict
    Messages: 1,308

    bad connection. yes i am positive. check the negative while your at it.

    now provide only ground and see if that cures it. if no provide only positive.
     
  5. LILsnowblazer

    LILsnowblazer Junior Member
    Messages: 14

    Bad connection where?
     
  6. no lead

    no lead PlowSite.com Addict
    Messages: 1,308

    between pos and neg posts on batt. or bat to solenoid or solenoid to grill plug. loosen all connections if possible, clean, grease and retighten.

    apply only ground to the pump and see what happens.
     
  7. LILsnowblazer

    LILsnowblazer Junior Member
    Messages: 14

    I cleaned up all of my connections and hooked everything back uo but the solenoid still clicks ad I stillhave no power =/
     
  8. TheEquineFencer

    TheEquineFencer Member
    Messages: 88

    Go get a volt meter, put one lead on the post on the solenoid coming from the battery and the other on the post going to the motor, read the voltage, should be close to what you have at the battery. Then energize the solenoid with the leads still connected across the solenoid, if it still reads battery voltage you have a bad solenoid, in a perfect world, it'll go to zero if the solenoid is good, in a less than perfect world you'll get a slight voltage reading, the higher the voltage reading across the terminals on the solenoid with it energized the worse the contact connections inside.
     
  9. tracer22j

    tracer22j Junior Member
    Messages: 10

    could be a bad solenoid had that happen with my minute mount
     
  10. TheEquineFencer

    TheEquineFencer Member
    Messages: 88

    I'm pretty sure that's what his problem is, the only other thing it might be is a ground problem. If he checks it like in the above post it'll tell him the condition of the solenoid and contacts inside the solenoid..If it's a ground problem, he can put one lead of the Volt meter on the Ground post on the battery and the other to the frame of the motor, when he energizes the solenoid if it reads much voltage over 1/2 volt he has a bad ground. I just had a buddy pick me up a spare solenoid, very Heavy Duty, $70 worth, 100% duty rated for 170 amps. I'm going to wire it right beside my OEM type, when the OEM quits I'll just change the wires from OEM to the new one.
     
  11. tracer22j

    tracer22j Junior Member
    Messages: 10

    nice good thinking
     
  12. TheEquineFencer

    TheEquineFencer Member
    Messages: 88

    Yeah, I try to learn from others misfortunes. I plowed for my buddy and the same thing bit him, sitting loosing $150-$200 an hour, a $70 solenoid get's real cheap. He just bought a box of 'em.
     
  13. highclimber604

    highclimber604 Junior Member
    Messages: 19

    AGREED!! One time in a pinch my buddys solenoid went on him, middle of the night, so i ran home and took the one off my Craftsman Lawn tractor(used to crank over the starter) just to get him through the night. worked the rest of the storm no problems! couldnt believe it. after the storm, he upgraded to the HD soly you are talking about.