1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

SnowEx v-Maxx control box repair ?

Discussion in 'SnowEx Products' started by jason@akehurst, Feb 7, 2013.

  1. jason@akehurst

    jason@akehurst Junior Member
    Messages: 1

    Here at the shop, we're running about 15 v-box spreaders. 9300's. We're having issues with the control boxes. Theres three plugs on back of box. One for main power. One in the middle, and the third one, two black & two red on top of each other--next to the prewet system output. This "two black two red" plug is the one thats breaking down. it looks like and appears that the plug is melting.And from this, the boxes start faulting out. Frustrating. From something ? I have two boxes here on my bench with identical problems. Does anybody know where I can get these boxes repaired ? Our company is located in MD. any help would be great.

  2. Sharpcut 1

    Sharpcut 1 Senior Member
    Messages: 386

    Got one on my bench off an 8500, same problem. Connectors get loose, then start melting, box thinks it's unplugged. Customer got tired of messing with it, has us replace box. Only $800.00 box. Replace the wiring harness end also, or you'll be doing it again soon.
  3. R75419

    R75419 Senior Member
    Messages: 135

    I have a 9500 an it threw an EO code on the spinner side this morning. We checked every connection under the hood, continuity front to back and isolated it to those connections (the red and black that are piggy backed). Hopefully someone comes up with an economical cure because harnesses and control boxes get pricey fast. We disconnected and reconnected several times than walah it started working. Too bad I had to have a buddy salt my lots before we found the solution.