1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

SnowEX sr-110 wireless spreader wont work

Discussion in 'Ice Management' started by plowin boy, Dec 1, 2009.

  1. plowin boy

    plowin boy Member
    Messages: 85

    I just recently bought a SnowEx wireless spreader and got it all put together and it wont work. The owners manual is terrible and the directions aren't very good anybody ever had any problems?
     
  2. Peterbilt

    Peterbilt Senior Member
    from IA.
    Messages: 745

    Mine work just fine.

    Whats it doing?

    J.
     
  3. THREE W

    THREE W Senior Member
    Messages: 122

    Mine also works fine, one of the things I did notice is that some wiring harnesses apparently need a different fuse which I thought came in the packet. perhaps you need to check, I dont think it covered it well in the instructions.
     
  4. THREE W

    THREE W Senior Member
    Messages: 122

    Couple of other things to check....

    1. the 7 pin trailer connector is ignition controlled so your vehicle ignition must be on.

    2. Have you ever used your 7 pin connector, perhaps it is not working

    If All else fails call snow ex at 800-837-0159

    hope that helps
     
  5. drpain09

    drpain09 Junior Member
    Messages: 7

    Two things....

    I had same issue, and got it working. But this thing clogs like crazy. Taking it back and getting a boss spreader...

    1. Chk your 7 way, make sure you have power to it. I have a 09 1500 Silverado and it didnt have power to the 7 way.

    2. You may need to reset remote, chk to see if the override position makes it run, if not, more than likely you need power to the 7 way...ie the + and _.

    if you need to reset remote, puch in a pin on back reset hole, hold 100% button down, then 50% then off. It should reset switch.