1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

SnowEx 1875 Chute

Discussion in 'Ice Management' started by procut, Feb 10, 2012.

  1. procut

    procut Senior Member
    Messages: 902

    I have a one year old Snowex 1875 Buk Pro tailage. It's sat for about 2 weeks and I went to load it today and turned it on while it was still empty like I always do to make everything is operating properly before loading it. I got the dreaded oL code on the controller. I got out and to my surprise the chute that dumps the salt on to the spinner was laying on the ground. It appears the two rivets that attach it somewhere rusted right out. I turned it off and back on and everything spins and works right.

    The problem is I cannot for the life of me figure out where the chute was attached to the spreader at. I don't know if there was another piece where that rusted off or what. I took two self drilling metal screws and accahed the chute back to the frame just so I could use it for the time being, but it doesn't spread right, it's throwing 95% of the salt to the drivers side.

    Does anyone have a picture or can describe where the chute attaches? The owners manual didn't have anything good and I can't find any views online like I need. Thanks!