1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

SnowEx 1075 problem

Discussion in 'Ice Management' started by VMAN, Dec 8, 2009.

  1. VMAN

    VMAN Junior Member
    Messages: 7

    My spreader keeps blowing fuse at battery due to auger clogged/jammed. I free it up and change fuse and everything is OK. I just paid to have this spreader transferred to another truck. The controller use to give me an error message of "OL" on controller when spinner/auger was stuck. Any help would be greatly appreciated.
  2. maelawncare

    maelawncare Senior Member
    Messages: 871

    i too have the OL problem sometimes. They way these work is weird sometimes. I have to go back to the spreader and manual spin the spinner sometimes to free it up. Then it runs fine. Might try that. If thats not it and it does keep blowing fuses. Then you might have short somewhere. I would check everything and make sure theres no bare wires or anything crimped up.
  3. T-MAN

    T-MAN PlowSite.com Addict
    Messages: 1,363

    How about moisture were the motor and trans is ? I had mine full of water several years ago. It blew alot of fuses. We re-wired it with heavier gauge wire, and crimped 2 spots on the cover for better drainage. I then just put in larger stainless sheetmetal screws were the rivets were. I did not use fluid film then, but I would coat the heck out of everything in there as well.
  4. Scottscape

    Scottscape Senior Member
    Messages: 662

    if your connectors already arent. Try greasing all connectors with dielectric grease heavily. If they aren't it has always seem to create alot of problems and give you that error message. The new control boxes do not have a fuse. You might want to try using a larger amp fuse as well and see if that helps.
  5. the_experience

    the_experience Member
    Messages: 75

    What kind of a fuse is it? For the cost of about 3 fuses you can get a self resetting breaker in ATM or ATC size. If you're dealing with something larger like a MAXI or a glass fuse they can get a little more expensive, but so does replacing a handful of fuses. It doesn't fix the problem, but it sure makes dealing with it easier.
  6. VMAN

    VMAN Junior Member
    Messages: 7

    The problem is I'm not getting the OL(overload) message on controller as before. If the auger was jammed it would give me the OL message without blowing a fuse. Now it blows a fuse everytime.I will check all wiring as well. I just don't want have to replace a fuse everytime the auger/spinner gets stuck. Thanks for all your input.
  7. VMAN

    VMAN Junior Member
    Messages: 7

    It has a ATM fuse at battery. I already tried upping the size.
  8. T-MAN

    T-MAN PlowSite.com Addict
    Messages: 1,363

    Thats the same thing mine did, you have a short. Did you pull the motor cover yet ?