1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Snowdogg MD 75 HELP

Discussion in 'Truck & Equipment Repair' started by walkerlawncare, Oct 1, 2015.

  1. walkerlawncare

    walkerlawncare Junior Member
    from WI
    Messages: 15

    Hello,

    I purchased a Snowdogg MD75 for my 2004 Ram 1500. I got it all installed and I am having some issues. The controller says everything is working normal (dogg is lit and has a green status light). The problem is that there is a clicking noise whenever I select l/r/u/d on the remote and the plow does not respond. I read to bypass the motor relay with jumper cables... I did that and the plow will run continuously to the left but will go right or up if I select that with the remote. Any suggestions on what to do? Any ideas are appreciated!!!! Thanks!!!!:mechanic:
     
  2. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,968

    While trying the u,l,r test light the solenoid and see if the signal wire is getting power, then check the output side to see if your getting power to the plow. Is the other small wire hooked up to a good ground?
     
  3. walkerlawncare

    walkerlawncare Junior Member
    from WI
    Messages: 15

    Thanks for the idea. I will take a look at it tomorrow. I was thinking it may be a ground or power to the solenoid as I just replaced the solenoid with no change in results. Hopefully this will tell me something new. The small wire is grounded to the frame on the same bolt that the battery is grounded to.