1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Snoway Problem

Discussion in 'Truck & Equipment Repair' started by gqnine44, Jan 2, 2007.

  1. gqnine44

    gqnine44 Junior Member
    Messages: 18

    I know there are some real Snoway troubleshooting pros on this site so hopefully you can help me figure out and fix what I screwed up...

    I have an older, 7 foot, 25 series plow with power down. I was given a 6.5 foot, 24 series (i think) plow with power down also. So I now have two plows. When I tried out the new plow the power down wasnt working but everything else was good. To try to figure out what the problem was I robbed parts off my old plow (which was working properly). After switching some stuff around I determined the problem was with the the power down valve (the thing beneath the coil). I figured I would just buy a new valve and I would have two working plows, so I started putting all the good parts back into my original plow.

    I used compressed air and blew off everything and put back all three pieces that screw into the power down "block". I then tried my original plow which was working fine before and now it didnt have power down. So I took everything off again and cleaned it again and put it all back. I still had no power down and now I didnt have up/raise. At this point I was pretty confused. I thought maybe I got too much rust/dirt down in the system and something got clogged so I followed the instructions in the repair manual and changed the fluid and cleaned the screen. I also removed and cleaned the raise/lower valve/solenoid and removed and cleaned the main pressure spring and ball. I tightened it 5 full turns. I now have power down, left, and right, but still no raise. When up is pressed on the switch the motor runs and the arm moves slightly but it doesnt lift at all. Any idea was is going on??

    Right now I have two plows - one that lacks power down (but I know why) and another that doesnt raise and I have no idea why. Thanks for your help!

    :help:
     
  2. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,992

  3. gqnine44

    gqnine44 Junior Member
    Messages: 18

    Thanks for the reply. When I got to the shop today I checked the wiring again to make sure I put everything back in the right place and it was correct. So it doesnt appear to be a wiring problem.

    It appears that when I press up it causes the cylinder arm to move the wrong direction but not enough to lift or act as the power down. I cant seem to figure out what the deal is.

    The only three things I messed with that may have caused this problem is the 3 things that screw into the port/box that has seems to be the power down controls. The manuals seem to give very little insight into the power down and what this stuff does.

    :help: Thanks!!