1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Snoway Plow, down pressure not working.

Discussion in 'Introduce Yourself to the Community' started by Curro, Jan 16, 2012.

  1. Curro

    Curro Member
    Messages: 53

    Not sure where to post this, there doesn't seem to be a Snoway section. I have a an older HTD model. I went out yesterday morning, we had sub zero temps over night and single digits to low teens all day. Hit the down pressure and nothing happens. The only thing I did that morning was top of the hydraulic fluid as I have a small leak coming from the lift cylinder. Not sure if I bumped something off or something froze up. Any help in the right direction would be appreciated.
     
  2. tuney443

    tuney443 PlowSite.com Addict
    Messages: 1,847

    I had that problem once.It was a short somewhere in the harness so I isolated the problem wire and just ran another one.First pull your cover and check all your connections.If not that get out your tester and start checking the circuits.
     
  3. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,993

    Everything works but the Down Pressure??
     
  4. Curro

    Curro Member
    Messages: 53

    Yes, everything works. The only slightly strange thing I notice was before I mounted the plow to my jeep it would want to move the lift cylinder when I depressed the left or right button. Got it on the jeep and everything was fine except for the down pressure.
     
  5. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,993

    You have the wired or the wireless control?
     
  6. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,993

    Have you removed the cover and made sure a wire has not come off/broke?
     
  7. Curro

    Curro Member
    Messages: 53

    Wired controller.

    Just went outside, I was waiting for the temps to reach above freezing. Removed the top and checked for loose or broken wires, nothing looked out of place. Hooked the plow up and the down pressure started working again?!?! Not sure if something froze up in the the lower temps or what. What I did notice was the rear seal on the lift cylinder has stated to piss fluid when the down pressure is activated. It was leaking a bit before but now its a lot worse. Is there a seal kit available or do I need to replace the entire cylinder?
     
  8. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,993

    Kit is available but it is often easier/better to replace the entire cylinder.

    Have you drained and flushed the unit?
     
  9. Curro

    Curro Member
    Messages: 53

    No I have not drained and flushed, should I? I also have a spare MT or Predator not sure of model (it has a Fenner pump) laying around I was going to use for spare parts. The previous owner gave me that one when I purchased the HTD. The lift cylinder on that one was replace not to long ago I was told. Would that cylinder be usable on the HTD? Thanks for your replies thus far..
     
  10. Wilnip

    Wilnip Senior Member
    Messages: 583

    If you are leaking fluid, its also sucking moisture in thru the same leak. It probably had moisture in it and froze up. I would replace the cyl, drain, flush, and fill.
     
  11. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,993

    The fenner pump does not interchange with the HT.

    the lift ram might however. I'll double check in the morning.
     
  12. Curro

    Curro Member
    Messages: 53

    Yeah that is quite possible. Going to replace cylinder than flush and refill.

    Yes, I am aware that the pumps are completely different. I was hoping the cylinders were the same. Please let me know when you get a chance. Also, if the are not compatible would you have a lift cylinder available?
     
  13. Curro

    Curro Member
    Messages: 53

    Ok, so the plow was acting up again today. Down pressure would not activate, then I noticed when angling the blade left or right in the down position, I would get down pressure? After awhile the DP started working as it should. Kinda strange that it was only putting DP when I angle the blade at first. I am new to Snoway and was hoping someone knows what is going on here. I plan to flush and refill the unit within the next few days and hope the helps..
     
    Last edited: Jan 21, 2012
  14. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,993

    Spool valve hanging up??
     
  15. Curro

    Curro Member
    Messages: 53

    Something else just happened. I went outside to disconnect the plow, forecast shows no snow for at least 5-6 days. Tried to start the Jeep and the battery was completely drained. Could it be a ground issue with the plow causing all these problems?
     
  16. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,993

    Did you leave it in float?
     
  17. Curro

    Curro Member
    Messages: 53

    yes it was on float with the control off. Is that a no no?