1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Snoway issues

Discussion in 'Truck & Equipment Repair' started by TPVILL, Mar 3, 2013.

  1. TPVILL

    TPVILL Junior Member
    Messages: 7

    I have an 06 model 29D Ibelieve. I've had issues in the past with solinoid relay problems. (have to replace it after a couple big storms) That usually fixes any slugish or spuratic operation. This season though, Ive been experiencing considerably slower up/down, and side to side operation. Changed the fluid last season. Levels check out good. Everything seems to operate but very slow. Could this be my pump motor perhaps? Anybody out there know of anything else that could cause this? It's been a good plow. I just need to get it back to efficient.
     
  2. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,992

    Yank the tank, clean the filter, check to see that the gelling/Paraffin/Glycerin haven't worked their way into the pump its self. Check and clean ALL electrical connections, positive and ground. Flush the entire system don't forget the screens in the manifold where the hoses attach.

    Refill with the proper fluid.

    Email if you have questions.
     
  3. TPVILL

    TPVILL Junior Member
    Messages: 7

    Thanks for the info. I'll get it pulled apart this week. Will email you if I can't get it resolved.
     
  4. Rick547

    Rick547 Senior Member
    from Indiana
    Messages: 535

    What flushing fluid would you recommend?
     
  5. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,992

    Meyer Hdyra-Flush.
     
  6. Rick547

    Rick547 Senior Member
    from Indiana
    Messages: 535

    I'll go out today and buy some at my local Myers Dealer.

    Thanks for the information.