1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Snoway 29R with Pro Control 2 Issues...

Discussion in 'Commercial Snow Removal' started by snow4me, Nov 24, 2015.

  1. snow4me

    snow4me Senior Member
    Messages: 126

    Anyone else having problems with their 2015 Snoway 29R Plow with the wireless Pro Control version 2?

    Issues I have noticed on first storm plowing:

    1.) Slow reaction to the input from the controller. What I mean is when I pull back to lift it does not react for sometimes a good 2-3 seconds. I am not sure if this is me or the controller because I have large hands and this controller is much smaller than pro control version 1 so sometimes I may be thinking I am pulling down to lift and because of the way it fits into my hand I am pulling slightly down and to the right instead of straight down. I plowed for 24 hours with this controller so I know what is happening but I do not know if it is like this for everyone or just my unit. I tried everything including looking down at it as I moved the joystick left or right and it is so position sensitive that if you are off by just a small amount the controller will not send the signal you are expecting to the receiver module. It's either that or perhaps this wifi signal is not strong enough or fast enough to respond quickly to commands being sent.

    NOTE: I like the fact it has a stronger spring mechanism inside the joystick thumb control because the version one was so weak it could easily get bumped and move when you didn't want it to.

    2.) Lift cylinder or hydraulic pump seems really weak. We just had an early season heavy wet snow storm and it was literally not lifting at all when I pushed a pile of snow to the edge of the asphalt. I had to put truck in neutral or reverse to remove some weight and allow the blade to lift.

    So that is what is going on...I figured I would try here first before I called my dealer to complain about this plow I bought.

    Anyone else have one with these same issues?
     
  2. Snoviper

    Snoviper Senior Member
    Messages: 121

    Have you checked the fluid level? I don't have the 29R but have the 29HD with the ProControl 1.
     
  3. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,992

    Not issues that we have been seeing. Take advantage of that 2 year warranty and get the dealer to fix it.
     
  4. 2005STX

    2005STX Member
    Messages: 39

    I have had a 29 series on my truck for about 6 seasons now and have gone through 4 controllers.. First snow of the season the other nite on my first lot and the controller just stops working This reason alone is why w
    I will not buy a snoway again Also even when new they are slow to react. Sorry if I hijacked your thread
     
  5. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,992

    you need to look for installation issues. that is not common. Maybe you have weak coils. Does the unit have black or blue coils? At that age the dealer should be checking resistance in the coils (particularly the "B" location coil) as part of the service.
     
  6. snow4me

    snow4me Senior Member
    Messages: 126

    Fluid level is fine. I checked all wires too and everything was tight. Left it with my dealer and they reset the receiver module and paired it again to the controlller because the wifi signal was weak. When the LED indicator for the wifi signal is partial orange and green colored it indicates a poor connection with plow reciever module. Fully green = strong signal. Mine was orange a lot on the first storm. Now it stays green until battery gets low. Charge it and signal inproves. FYI If anyone has their controller stop working remove the screws and look for two 1/8" round magnets. They are supposed to be glued,into the face cover however the glue they use is weak. Mine fell out and unit stopped working. Had to find magnets which will likely stick to your battery. Buy instant fast setting super glue not the gel. Reglue these into the cover and use hair dryer on high heat to get glue to dry faster. Reassemble making sure copper wire is outside printed circuit board. Charge fully and you should be back in business. If not try pairing procedure to reconnect to receiver module. Another small but annoying Snoway electronic issue. Love my 29R and getting used to the pro control 2 but it still too small for my big hands and button layout is too small for my liking. IMHO all they needed to do is to replace old loose easily broken thumb joystick with the new version which is beefier and springs are stronger to prevent accidental inputs from a slight bump against something when setting down with unit on.