1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Snow EX Spreader Not Working

Discussion in 'Truck & Equipment Repair' started by Hambrick & Co., Dec 5, 2008.

  1. Hambrick & Co.

    Hambrick & Co. PlowSite.com Addict
    Messages: 1,350

    I have a Snow Ex 325 spreader but its not working. I have metered the switch, checked the fuse and metered the plug in the rear of the truck all have power (11V). Cant figure out why the motor wont work. The auger spins manually but not under power when the switch is activated. Any one have any info that may help. Spreader is less than 1 year old.
     
  2. dirtmandan2

    dirtmandan2 Senior Member
    Messages: 275

    i have an 1875 so not sure if its the same... mine did the same thing, the spinner and vibrator both ran but not the auger. i drilled out the rivets to get to the auger motor and transmission and the wire connector there needed cleaning and grease...
     
  3. dirtmandan2

    dirtmandan2 Senior Member
    Messages: 275

    oh and when i put it back together i used stainless steel self tappers and sealed everything with silicone so nothing could get in there.
     
  4. Rc2505

    Rc2505 PlowSite.com Addict
    Messages: 1,245

    I have a 325 spreader as well. I don't know what to tell you as to what to look for or anything, but since the thread is open.... When your was working how did it do for you? I just bought mine this October. I have never been more dissapointed with a new purchase of anything before in my life. I have heard alot of good things about Snow-ex, but as far as I am concerned I am looking for something else at this point. I can do a better job with a push spreader, and call it good.
    Good luck with your spreader. Call Salt-ex customer service and see if they can help you out. They have a two year warranty on these.
     
  5. Hambrick & Co.

    Hambrick & Co. PlowSite.com Addict
    Messages: 1,350

    I took the housing off to expose the motor. tested the quick connect located in the motor housing have power all the way up to that point. So I am thinking it has to be the motor.

    The spreader worked fine for me last year. It served its purpose. I need to get a bigger spreader as we picked up some larger accounts but I wanted to keep this as a back up.
     
  6. Rc2505

    Rc2505 PlowSite.com Addict
    Messages: 1,245

    Hambrick did you ever figure out what went wrong with the spreader? Mine pucked out on me last night. I have the exact problem. This unit is only 1 month old, and I think the motor is junk. I have officially used it to spread a total of 12 bags of salt, and it's done for. I will take it in to the dealer tomorrow morning, and see if they can do anything to get me going again.
     
  7. GSU Lawn

    GSU Lawn Member
    Messages: 48

    I'll tell you I had the same problem with my 325 not once but twice. Had to replace the motor both times. The bearings inside the motors are seazing up and the people I talked to that replaced the motor said this is a major issue with the snowex 325. This last time I sealed the cover real good to maybe help keep this from happening again.