1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

sno-way won't go up

Discussion in 'Sno-Way Discussion' started by bwhandy, Nov 27, 2005.

  1. bwhandy

    bwhandy Junior Member
    Messages: 6

    I'm putting power to the pump moter . there is whirling but not going up. Ican put power to the moter with power to the right and left wires and they work .does anyone have ideas where to start. Thanks in advance
     
  2. festerw

    festerw Senior Member
    Messages: 986

    Have you changed the fluid lately it's possible there is air in the lift cylinder.
     
  3. bwhandy

    bwhandy Junior Member
    Messages: 6

    no I haven't changed the fluid. But I've the plow over two years and haven't ever run it until now. So I don't know If this thing even worked right when I got it. I bought the plow with no harness or controller , so I built my own but it wasn't working so I've gone back to where I should have started with testing the unit on its own. Thanks for your reply
     
  4. festerw

    festerw Senior Member
    Messages: 986

    Well it wouldn't hurt to change the fluid if it's been sitting for 2 years, you could also try applying power to the 'lower' solenoid and physically move the lift cylinder up and down a few times then reconnect power to the pump and see if it raises
     
  5. bwhandy

    bwhandy Junior Member
    Messages: 6

    I've got it working now,in case any one else has a problem . the dealer in MN said it would be the lower valve stuck open. But it turned out to be the 4-way valve stuck open,so it was just cycling fluid around.