1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Sno way nightmare

Discussion in 'Residential Snow Removal' started by Westworld, Jan 30, 2007.

  1. Westworld

    Westworld Junior Member
    Messages: 1

    I am having yet another problem with my two year old snow way plow. This time it is totally dead at the hand controler. Does anyone know how to get it on to the truck without power so that I can get it to the dealer? I can get the bottom pins in but I can not get the center pin in without power to the center cylinder. I do have power to the motor but that is it. The fuse is good. When I bridge the terminals between the solenoid the motor runs but nothing happens.
     
  2. bryanj23

    bryanj23 Senior Member
    Messages: 135

    If you haven't already, I would suggest posting this question in the Snoway specific forum on this site. You may have better luck meeting up with somebody who knows more about your specific plow.
     
  3. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,992

    jack the plow up until you can put the center pin in.
     
  4. PLOWMAN45

    PLOWMAN45 2000 Club Member
    Messages: 2,835

    another snoway happy customer
     
  5. Aw, c'mon I'm sure there are "problem" threads in the other manufacturer forums too!

    Edit: i need to learn how to spell!
     
    Last edited: Jan 31, 2007
  6. PLOWMAN45

    PLOWMAN45 2000 Club Member
    Messages: 2,835

    i have taken alot of crap for using western curtis and meyers but i never had a problem
     
  7. why would anyone give you a hard time about curtis and especially western and meyers? I think those two are some of the most popular and respected brands.
     
  8. stangman35

    stangman35 Senior Member
    Messages: 267

    Sounds like the hot wire coming from the controler isnt getting power,if you havent fixed it already.Had the same problem on the boss'es v-plow.