1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Sno-way mega v

Discussion in 'Commercial Snow Removal' started by snowsn8k, Jan 18, 2011.

  1. snowsn8k

    snowsn8k Junior Member
    Messages: 1

    Has anyone else had electrical problems with their plow? I need help with mine. I have replaced the harness, its been looked at multiple times, and im still getting ghosting issues. Before the plow would just become motionless no matter what was pushed, but i learned to turn it off and on again to make it work for awhile.Now the remote beeps every 3 seconds flashing relay fault on screen.Regardless everything works the beeping is just annoying. The plow has seen 3 differant dealers all who say something differant every time its brought in. Ive called snoway multiple times just to have them tell me to go to a dealer. This is unbelievable how bad their customer service is! These plows are not cheap, but when they work they are awesome.Can anyone help ,or has anyone else had these issues with electrical ghosts?
  2. hydro_37

    hydro_37 PlowSite Veteran
    from iowa
    Messages: 3,790

    how old is the plow?
    if it is the first year series of Mega V....then good luck with it....lol
    thats why there is NO sno-way forum anymore...they got so much crap for that blade