1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Sno-way 29 series problems / controler

Discussion in 'Sno-Way Discussion' started by plummer.62, Jan 9, 2009.

  1. plummer.62

    plummer.62 Junior Member
    from Indiana
    Messages: 3

    On my 29 series Sno-way w/Down Pressure. I've developed problems of course right in the middle of a great snow. After plowing for an hour or so, everything working just fine, my plow died. The controller lights all went out except the DP button. No controls would work. Doesn't matter if I plug it in at the Plow or in the cab. I let it set for a couple hours and went out and the whole controller lit up and then the plow lifted but when i dropped it to test controls it died again. Anyone with any ideas what is the problem??
     
  2. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,992

    No idea, sounds like it could be new control time. Never had one stop all functions except the one, normally they either work or don't work. Get your dealer to throw a test unit in it to make sure it is the transmitter not the receiver.
     
  3. plummer.62

    plummer.62 Junior Member
    from Indiana
    Messages: 3

    More info

    To explain more, it's a wired controler. But when it was , on working fine, the entire controller was lit up like normal. Then all the buttons went out except the dp , while the plow was down, and i had no functions at all. After letting it sit for a couple hours then it started working again, for s short second enough to lift and then drop once and then the same problem. I'm going to try a local dealer this morning but unfortunatly I've got a ton of snow to move and no plow to do it with till then.
     
  4. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,992

    Look for a short. The control has an internal self resetting "relay" if it's power supply or grounds are compromised the unit will shut down. Disconnecting it and allowing it to sit for a while (5-20 min.) and it will reset. It could be a failing (failed) receiver (black box under the pump cover) it could be a pinched, broken, or corroded wire, or it could be a bad control. Check to see if there is a steady 5 volts emitting from the receiver and that the all the grounds are in place, have continuity and are corrosion free. check the control signal wire for continuity. Focus particularly on the plug assemblies, they will get un-screwed improperly and break wires sometimes allow momentary or low voltage.

    If it does work properly when first connected try angling the unit and/or applying the DP. It could be the lift command cycle is compromised somewhere.

    All that said the first thing I'd do if this was in my shop was test it with another "known" good control. quick, simple and straight forward.
     
  5. s_melchi

    s_melchi Senior Member
    Messages: 183

    I got him back up and running today.
     
  6. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,992

    So elaborate please
     
  7. s_melchi

    s_melchi Senior Member
    Messages: 183

    Replaced Coil 96111171 location B.

    That thing was smokin hot when we took off the cover. Seemed the most logical place to start. Replaced it and I haven't heard anything back from him.

    Not sure why it was making the control all wacky.
     
  8. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,992

    :eek:Was the coil black? did you replace it with a blue one? Could be a warranty and you should change out the other two. Get the serial number and check with Andy. Yes they screw with the control it's a voltage issue. the Three concerned are front center rear center and passenger side rear.

    This is something the others having similar control problems should look in to. I don't know why I didn't think about it before. They will eat receivers.
     
  9. s_melchi

    s_melchi Senior Member
    Messages: 183

    Yes it was black. I changed it to a Blue One.
     
  10. plummer.62

    plummer.62 Junior Member
    from Indiana
    Messages: 3

    Is there a way for me to check the warranty or does it have to be checked by a dealer? I bought the plow used but I believe it's only a year or two old. The serial number is 29D100293
    Any help is greatly appreciated.
     
  11. s_melchi

    s_melchi Senior Member
    Messages: 183

    I will email tech support and find out.