1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Smart Hitch won't raise when mounting

Discussion in 'Boss Plows Discussion' started by 160ClassBuck, Nov 29, 2013.

  1. 160ClassBuck

    160ClassBuck Member
    from WI
    Messages: 37

    Read through many older threads before posting but here is my problem.

    When going to mount plow onto truck, put hand controller in float and raise SH switch on tower. Pump kicks in but no movement. No magnetism at SH coil so swapped out with coil to the left of it and same issue. Checked voltage and only have 6.5v coming at the coil. Changed out both ends of black wire to ensure good contact. Thinking bad switch?

    When plow is mounted, up/down, right/left is fine.

    Any suggestions on where to go next?

    Thank you,
    Dave

    [​IMG]

    [​IMG]
     
  2. 160ClassBuck

    160ClassBuck Member
    from WI
    Messages: 37

    Update: so by the switch I put a jumper wire from the middle orange (10V) terminal down to the black terminal and hit up the SH switch. Wala!, magnetism at the coil and the lift cylinder pushed the SH rack up.

    Now pretty sure the switch is bad but anyone with more experience could you please confirm?

    Thank you,

    Dave
     
  3. jhenderson9196

    jhenderson9196 Senior Member
    Messages: 615

    I have replaced 2 on my plow in 10 years.
     
  4. Ultra Duty

    Ultra Duty Member
    from NE OHIO
    Messages: 65

    Can a switch like this be found at a Napa?? dealer wants like $45
     
  5. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,968

    No. It's a special switch. The 2 middle pins are horizontal not vertical
     
  6. 160ClassBuck

    160ClassBuck Member
    from WI
    Messages: 37

    Guys, thanks for the replies.

    Is there any other way to know if the switch is bad or other testing beyond what I have done so far?

    Thanks,

    Dave
     
  7. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,968

    I can play around with one here at work later on. Or tomr
     
  8. Ultra Duty

    Ultra Duty Member
    from NE OHIO
    Messages: 65

    thanks for the imput, figured it was a Boss only switch..
     
  9. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,968

    I just ordered some online from A supplier. I think like 36.00. Or so. Search boss or blizzard hitch switch it'll cone up
     
  10. mypolaris1

    mypolaris1 Member
    Messages: 59

    So a new switch fixed it?
     
  11. plasticman92

    plasticman92 Junior Member
    Messages: 2

    what type of lights do you have on this plow? i only ask cuz i am trying to wire up the smarthitch option on a plow i just got and was wondering about how the brown wire from marker lights are supposed to be grounded.
     
  12. maxwellp

    maxwellp PlowSite.com Addict
    Messages: 1,112

  13. mypolaris1

    mypolaris1 Member
    Messages: 59

    I had the same problem. Funny thing on mine it works when the truck is running, but not if just key on. Everything else works, angle and up/down if key on. Does it draw that much power lifting itself up?