1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

smart hitch problems

Discussion in 'Boss Plows Discussion' started by beeto24, Dec 1, 2009.

  1. beeto24

    beeto24 Junior Member
    from buffalo
    Messages: 2

    i am also having problems with my smart hitch. so far i changed the switch ,changed power and ground connector,cleaned up contact points on frames,thinking it was a ground issue.the motor is working .if i manually get the plow hooked up it works fine in both functions.this is a smart hitch 1 i believe.it has a 2 position switch.i still think it has something to do with a ground. i switched valves and solenoids around to try to eliminate that as a problem.need help.
     
  2. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    You've done some good work already but still need some further checking. Have you checked the lift, lower and smart hitch coils for magnetism while simultaneously attempting to power the lift tower up? If not, you need to do so next.
     
  3. beeto24

    beeto24 Junior Member
    from buffalo
    Messages: 2

    i checked for magnetism but only have it on one coil.im not sure which coils should be magnetised at the same time for lifting the frame.
     
  4. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    If you only have mag on one coil thats why it won't attach. Need to have it on all three coils with the white, orange, and black wires simultaneously during attach.