1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

smart hitch on 2006 8'2" pover v ????

Discussion in 'Boss Plows Discussion' started by BMPM, Feb 21, 2007.

  1. BMPM

    BMPM Member
    Messages: 38

    problem with smart hitch on 8'2" power v

    here is my problem my smart hitch wont work to hook up plow or unhook plow. the plow works great but it wont lift to hook to the truck or unhook when i hit the switch on the light tower. I had to replace a valve the other day and had to add fliud. I'm thinking there is air in the cylinders. Anyone got any ideas on this or had the same problem?
     
    Last edited: Feb 21, 2007
  2. THE05HD

    THE05HD Member
    from WI
    Messages: 74

    WHEN YOU PUSH THE SWITCH UP OR DOWN, DOES THE PUMP RUN ?

    HOW MUCH FLUID DID YOU ADD, AND DID YOU PUT BOSS HYD. OIL BACK IN ?

    AARON :)
     
  3. jce4isu

    jce4isu Senior Member
    Messages: 289

    check the wire under the cover
     
  4. DaySpring Services

    DaySpring Services PlowSite.com Addict
    Messages: 1,065

    Dumb question, but are you in float?
     
  5. mdd

    mdd Member
    Messages: 48

    sometimes mine wont raise,not sure the cause but i hear the pump running when i flip the switch it just wont raise.

    i just go to the front of the plow and push the light bar into the truck and it goes up after tht just fine
     
  6. BMPM

    BMPM Member
    Messages: 38

    yea the pump runs when i hit the switch either way. I put genuine boss fluid in it also. If i push the tower to the truck and have the levers in the on position it goes right on and the plow works perfect. If i take it off i put the latches in off position and have to manually pull them to unlock them and push the tower forward to remove it. I also have it in float the whole time. Just dont make sense to me.
     
  7. LwnmwrMan22

    LwnmwrMan22 PlowSite Fanatic
    Messages: 27,998

    Once the tower is up, the plow is on the truck........

    When you're taking the plow off, and you've flipped the metal levers to "off".....

    Before you just push down on your lever, have you tried pushing up on the lever first??

    What this will do is push the tower up, just a hair, releasing the pressure on the pins, and the pins should then pop out on their own.

    I've been told by my dealer it's a self bleeding system. It'll push it's own air out.
     
  8. BMPM

    BMPM Member
    Messages: 38

    thanx i'll try that and see what happens
     
  9. Allamand

    Allamand Junior Member
    Messages: 8

    I seem to be having this same problem on my 7' sport boss. My normal removal is just as LwnmwrMan22 stated it, yet when I hit the toggle swicth down on the light tower, all I hear is the pump running and nothing happening.

    Have you found a fix yet to yours BMPM?
     
  10. BMPM

    BMPM Member
    Messages: 38

    no i am waiting for the smart hitch valve. I order one from central parts and they are on back order from Boss. So I have doing it manually! I'll post it on here when i get it to see if that works.
     
  11. wild bill

    wild bill PlowSite.com Addict
    Messages: 1,239

    smart hitch

    have you checked to See if you are getting power to the smarthitch valve?is the coil working? check for magnetism the switch it self may be bad.
     
  12. sweetlou48096

    sweetlou48096 Junior Member
    from 48096
    Messages: 28

    That toggle switch always scared me, too many people that I have spoken with seem
    to have a problem with it. How much was the hitch valve you have on order ? I really
    like the hiniker quick hitch system, simply child proof and easy, drop the kick stand,
    flip one lever for both sides of the truck, unhook the electrical.....wala....unhooked and
    just as hooking up, just reverse the process. No electric, no hydraulics, and no getting
    in front of it and pushing it up. I really thought it would have been the switch, so many
    of my friends have replaced theirs. Well good luck with it.
     
  13. jrglandscape

    jrglandscape Member
    Messages: 40

    I had the same problem on my 9'2' ploy vee plow. It ended up being a bad ground on the the plow side. The coil hydraulic valve. I belive it was the one with the white wire running to it. I ran another ground and no problems since. Just hooked it up a few days ago to put it in the garage.

    James