1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Smart hitch issues

Discussion in 'Boss Plows Discussion' started by RBRONKEMA GHTFD, Nov 27, 2011.

  1. RBRONKEMA GHTFD

    RBRONKEMA GHTFD 2000 Club Member
    Messages: 2,592

    A buddy of mine is having issues with his smart hitch switch on the light tower. I honestly think its not getting power as I hooked my test light to it and with the controller in float we hit the switch up and down and got nothing. All the grounds are good and tight on the plow and truck. He did try and replace the switch also and still nothing. Any thoughts? I went thru my book trying to help him out but can't figure it out.
     
  2. doo-man

    doo-man Senior Member
    Messages: 387

    Check fuses on harness under hood, also I think there is a relay that controls that mode hope B&B chimes in to point you in the correct direction if that didn't help !
     
  3. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    The SH switch receives it's power from the lower coil (orange wire) so start at it and check for power over to the switch.
     
  4. RBRONKEMA GHTFD

    RBRONKEMA GHTFD 2000 Club Member
    Messages: 2,592

    Sounds good will do once I get back into town. Thank B&B
     
  5. Deckscapes

    Deckscapes Senior Member
    Messages: 241

    Also check the 13 pin connectors, if the 13th pin is missing or broken the SmartHitch will not work
     
  6. RBRONKEMA GHTFD

    RBRONKEMA GHTFD 2000 Club Member
    Messages: 2,592

    If I don't have power at the orange wire what should my next step be? Where does the orange get its power? Never had to deal with a issue like this before. I was going to see if I could run a jumper wire from the battery to the switch to see if I could get power that way for temp just to test it. Is it possible the coil is bad? The guy who had it before hand said it quit working and he just never did anything about it. The smart hitch on his vee he has now works. So I know its not truck side.
     
  7. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    The orange wire is the lower/float wire and should have power anytime the controller is in the lower/float position, controller on of course. Without power there the SH won't work and neither would the lower function if the plow was attached. So it isn't a SH issue- the issue is the orange wire doesn't have power from the controller.

    Start back tracking from the controller plug through the harness to see where it loses power. It's orange all the way from the controller to the lower coil and is pin #4 in the bumper plug so it's not hard to find/follow.

    You can run a fused jumper directly to the lower coil just to test as well but I suspect you'll find the issue rather quickly anyway.
     
  8. RBRONKEMA GHTFD

    RBRONKEMA GHTFD 2000 Club Member
    Messages: 2,592

    Alrighty, Talked to my buddy some more today, the plow functions just fine, up, down, left, right. Just no SH. I'll see if I can take a look at it this weekend and try and figure it out.
     
  9. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    If it will lower Ryan then the orange wire must have power in it. Perhaps your prior test was skewed. Go over it again once you have it in front of you. You should have power at the orange right at the coil and on the orange jumper that goes from the coil over to the SH toggle. Check those first and perhaps you actually did have power there and the #13 pin is just broke off in the bumper plug. This will give the impression that the toggle isn't working but in fact it is, the power just isn't getting back to the underhood solenoid (from the toggle) to actually run the pump since the pin is missing from the bumper plug.
     
  10. danrewerts

    danrewerts Junior Member
    from Iowa
    Messages: 1

    SH has no life

    i bought a 7'6" poly from a friend, only has 2 season on it and everything worked fine when we mounted and ran everything 3 weeks ago. i went to hook it up tonight for our first snow and i got nothing from the SH. i have power everywhere else but nothing from SH. the only way i could get my plow to hook up was to have someone in the cab using handheld controller while i simultaneously SH then it worked 1/2 the time. any thoughts??
     
  11. erkoehler

    erkoehler PlowSite Veteran
    Messages: 3,265

    Clean all your connections, tighten battery terminals and clean, check voltage.
     
  12. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    The controller must be in the float position for the SH toggle to work.