1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Small issue with plow

Discussion in 'Western Plows Discussion' started by Frozen001, Sep 18, 2006.

  1. Frozen001

    Frozen001 Senior Member
    from Rome NY
    Messages: 908

    Okay so I moved my plow yesterday to d some cleaning in my garage, and for some reason it doe not go up as high as it did when I put it away at the end of the season. when I first raised it it stopped like 2 inches short, and it made this terrible creaking sound right before it stopped raising. I checked everything out and it does not seem to be binding up on anything. I have yet to change the fluid for the new season, so I am hoping that is all it is. Also I noticed when I held the up button on the control it would drift ever so slightly to the left. Any thoughts??
     
  2. Robbie Rooster

    Robbie Rooster Member
    Messages: 33

    Did you remember to remove the pin from the stand? I'm sure you did, but I've done it before. Plow goes up slow, creaks, then bends the pin.:cry:
     
  3. Frozen001

    Frozen001 Senior Member
    from Rome NY
    Messages: 908

    no pin on the stand... it's an ultra mount.....
     
  4. Brannick's Snow

    Brannick's Snow Member
    from ohio
    Messages: 48

    Check the fluid
     
  5. Synergyracing

    Synergyracing Member
    from Indiana
    Messages: 54

    better yet.. change the fluid....
     
  6. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,992

    Packing seized to the lift ram. Try penetrating oil around the packing gland. I've had to loosen them.
     
  7. Frozen001

    Frozen001 Senior Member
    from Rome NY
    Messages: 908

    Ok I un hooked the lift chain and the lift ram went right up to it's max height with out a problem, so now I am really lost...
     
  8. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,992

    Could be a bad Hydro. pump, throw a pressure gage to the unit see how many PSI the pump produces.
     
  9. Frozen001

    Frozen001 Senior Member
    from Rome NY
    Messages: 908

    Man the plow has only seen 2 seasons... I hope it is not the hydro pump....