1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Slow lifting pump

Discussion in 'Western Plows Discussion' started by fatboy, Dec 6, 2006.

  1. fatboy

    fatboy Senior Member
    Messages: 222

    Hi, new guy here. looking for opinions on my Unimount pump.
    I noticed it was working slower then normal so I changer the fluid and filter screen.
    It seems to be better while angleing left to right but still seems very slow lifting.
    I saw some small fillings on the filter screen when I changed it, is my pump worn out??
    I also just installed a new cutting edge and back drag edge, would this add to my problem?
  2. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    First thing to check is all your batt cable connections,make sure there all clean and tight. Especially at the grill connectors.
  3. Snoflo

    Snoflo Member
    Messages: 57

    First of all having some shavings in the filter and on the magnet is pretty normal. Motor may be wearing some or motor solenoid could be weak. As suggested above check for coroded connections, next check the quill adjustment and try backing it out for faster operation, also check the O-Ring on the bottom of the pump it may be worn and net sealing well.
  4. fatboy

    fatboy Senior Member
    Messages: 222

    slow lift

    The connections should all be fine, I just re&re the plow from one truck to another and all connections were removed, cleaned, and had dielectric grease applied.

    The O-ring your referring to is the one on the bottom of the pump to the housing, right?
    I didn't think to replace that when I had the pump out because it looked o.k. but I will try that anyway.

    The plow drops plenty quick and angles good to it just raises slow, it seems like its really
    labouring to lift like its just too much for it to lift!

    Thanks guys,
  5. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Since you said this was an R&R, did the pump sound like it was struggling when it was on the other truck? If it did I'd replace the motor.If it didn't I'd suspect the battery.