1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Slow angle to left

Discussion in 'Meyer / Diamond Products Discussion' started by Banksy, Jul 22, 2006.

  1. Banksy

    Banksy PlowSite Veteran
    Messages: 3,113

    I have an old school Meyer C-8 with the double toggle switch controls. I'm not sure what model the pump is. It seems to lift fine and angle right fine, but the pump runs for a good 5 seconds before it angles left and sounds like it is straining. The negative cable on the battery gets very hot too. I noticed that because it was burning the electrical tape around it and smoking. What gives with both these issues?:confused: Thanks.
     
  2. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,992

    Hot cable on the ground side, clean the ground connection, check to see if the conections are good, and weither the cable it'self is corroded.

    Slow angle to the left check the filters and the B cartrige and coil. could be a sticky or partialy closed soliniold or a weak coil.

    You can download the repair manual at the meyer web site
     
  3. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,992

    Hot cable on the ground side, clean the ground connection, check to see if the connections are good, and whether the cable it'self is corroded.

    Slow angle to the left check the filters and the B cartridge and coil. could be a sticky or partially closed solenoid or a weak coil.

    You can download the repair manual at the Meyer web site
     
  4. Big Dog D

    Big Dog D PlowSite.com Addict
    Messages: 1,134

    You said that it was lod so don't forget to check that the hydraulic quick couplers are working properly too. If they are clogged they can cause similar symptoms.
     
  5. Banksy

    Banksy PlowSite Veteran
    Messages: 3,113

    I'll clean all the connections. All the solenoids on the pump are brand new. However, one of te quick couplers is a little funky. I have a spare. Thanks. What fluid can I use to replace the fluid thats in there? On my old Fishers I used tranny fluid in the pump. Same thing?
     
  6. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,992

    Meyer fluid. Clean the Filters.
     
  7. Banksy

    Banksy PlowSite Veteran
    Messages: 3,113

    Thanks. Hopefully this advice will take care of it.