1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Shaft pto problems

Discussion in 'Truck & Equipment Repair' started by rick17, Dec 12, 2009.

  1. rick17

    rick17 Junior Member
    from MN
    Messages: 7

    I have a front mount chelsea 450 pto (runs off the engine shaft it an old city plow/sander). A couple of days ago my guys had a hose leak in the spreader and they lost about 15 gallons and didn't know it until the plow wouldn't raise anymore. I refilled the hydro tank now nothing works, I can feel in the plow controls the lever is free moving, the dump feels solid but wont raise. I think I have air locked the pto, any tips on how to repair? I have loosed fittings on the plow to try to push out air, but nothing will come out no pressure at all.
     
  2. no lead

    no lead PlowSite.com Addict
    Messages: 1,308

    get the wd-40 out. go down to the pto/pump and spray the hose fittings at the pump. crack open the pressure line and let the oil siphon through the pump. make sure the shut off valve from the tank is open.
     
  3. Plowfixguys

    Plowfixguys Senior Member
    Messages: 222

    You could put a little air pressure in the tank to push the fluid to the pump, use an air blower nozzle and a rag to get a seal around the filler tube.