1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Service 4WD light on

Discussion in 'Chevy Trucks' started by DCC, Feb 5, 2011.

  1. DCC

    DCC Junior Member
    Messages: 3

    I have a 99 silverado 1500 and the service 4WD light is on but 4x4 works fine. Any thoughts?
     
  2. MrPLow2011

    MrPLow2011 Senior Member
    from Boston
    Messages: 276

    My thought would be to service it
     
  3. jchart06

    jchart06 Junior Member
    Messages: 25

    several things, i had an 03 the service light would come and go on the 4x4, mine was a combination of the wheel sensor being bad and the sensor in the transfercase. one is a cheep fix the other rather expensive its worth paying someone or place with a computer to hook up and figure out at least what code its throwing, because it could be anything from a pinched wire to the actuator having a high resistance were it still functions just not all the way which cause MAJOR damage if you get it in a bind were you are using max power and traction to pull through your obstical. same goes for the wheel sensor a bad wheel bearing could be causing a miss read or a bad sensor and could cause significant issues
     
  4. marylandbigb

    marylandbigb Member
    Messages: 87

    have codes pulled in 1999 they had a lot of problems with the switch throwing codes u may have an encoder/actuator isuue too it is not going too be a wheel speed sensor because that would set an abs/brake light not a service 4wd light get it scanned before it leaves u stuck
     
  5. jchart06

    jchart06 Junior Member
    Messages: 25

    i thought the same thing bout the abs light but the only light was the 4wd light and the second time it came on thats what was the problem, something bout when it was locked in the preasure of the front end locked in caused it to quit reading the driver side. but the abs light never did come on, once i put the $465 wheel sensor in the problem never came back
     
  6. marylandbigb

    marylandbigb Member
    Messages: 87

    cant say i have ever seen that... been a gm tech for 25 plus years and have never seen it.. anythings possible i guess
     
  7. chevyzrule810

    chevyzrule810 PlowSite.com Addict
    Messages: 1,239

    my 06 service 4wd light started comming on at 48,000 and it works fine.The only thing that lights up on the switch is the orange indicator light,no backlight and it goes into 4x4 no problem trucks got 54,000 on it and it still works and the service 4wd light comes on now and again.
     
  8. mrv8outboard

    mrv8outboard Senior Member
    Messages: 197

    There is a service bulletin from GM on the encoder wheel issues. Also there is a repair kit so you do not need to buy the whole encoder motor. In it as well is something about a grinding noise in the front end and the engagement mechanism.
     
  9. jgsxr750

    jgsxr750 Member
    Messages: 84

    my 05 had the same issue and i changed the 4x4 switch first and still had the light come on. them all the lights went out on the switchand truck would not transfer into 4x4. so i changed the encoder motor in the transfer case. pretty pricey for this and the 4x4 worked perfectly. truck had 100k miles at this point. the light started to come on and off at 95k.
     
  10. t-sig

    t-sig Senior Member
    from 607
    Messages: 121

    I had the same message on my 2000 Silverado 1500, but, it eventually wouldn't go into 4 wheel either. It turned out to be the push button swithes in the dash. Replaced it at about 70k miles and no more problems since. Easy do it yourself repair, if that is the problem...
     
  11. mrv8outboard

    mrv8outboard Senior Member
    Messages: 197

    I find GM will always quote you an encoder motor and not the repair kit. There is a repair kit if it is only the sensor part and not the motor it self. The repair kit is like $68.00 or something like that.
     
  12. bradhow79

    bradhow79 Member
    Messages: 37

    t-sig has it right
     
  13. chevyzrule810

    chevyzrule810 PlowSite.com Addict
    Messages: 1,239

    if I replace the 4x4 switch as only the indicator light is the only thing that lights up,will the service 4wd light keep comming on?
     
  14. t-sig

    t-sig Senior Member
    from 607
    Messages: 121

    If the switch is the problem, then no, you won't get the service 4wheel drive message anymore. Someone explained it to me like this, the computer pings the sensors for info, if that connection is interupted, then the message will come up. The bad switch could be the interuption. The message also comes up for problems with the 4 wheel drive components, so, this isn't a sure thing. But, it sounds like you already have some sign of problems with the switch if the lights aren't working.
     
  15. jgsxr750

    jgsxr750 Member
    Messages: 84

    t-sig is correct... first change the switch and see what happens...then we did the service kit. but that didnt help either had to do the whole encoder motor on my truck. after the new motor was put in message went away and it transferred perfectly. . the dealer didnt tell me it was the encoder motor it was a transmission place that deals with trucks only, and i have used them for many years and my old job used them to work on there truck (which we did a lot of towing and plowing with.) very trust worthy place. place even gave me a loaner truck with plow when mine was down with this 4x4 problem.. where do you see that theses days.
     
  16. mrv8outboard

    mrv8outboard Senior Member
    Messages: 197

    Go to your local Autozone and have them retrieve the DTC's. This is were to start. Post the DTC's and we go from there.
     
  17. mrv8outboard

    mrv8outboard Senior Member
    Messages: 197

    Also, depending on were you are located I could put it on my Genesys scan tool and retrieve the codes.
     
  18. chevyzrule810

    chevyzrule810 PlowSite.com Addict
    Messages: 1,239

    I work at a dealership in service I will scan the truck for codes,just wanted to get an idea of what other guys have run into.