1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Serious wiring issue!

Discussion in 'Fisher Engineering Discussion' started by chevyzrule810, Dec 25, 2012.

  1. chevyzrule810

    chevyzrule810 PlowSite.com Addict
    Messages: 1,239

    My friend bought a plow and he had it delivered to his house by the guy he bought it from.Plow is a mm1 three plug with an insta-act pump.Trucks a 2005 2500hd.When the up button is pushed on the fish stick the radio shuts off then turns back on the abs light comes on and the service airbag shows up on the information center.What would cause this?
     
  2. Banksy

    Banksy PlowSite Veteran
    Messages: 3,113

    Sounds like the red power wire for the joystick was wired into something it shouldn't have been. That's my initial thought. I had that wire spliced into my cig lighter (key on hot only).
     
  3. RepoMan207

    RepoMan207 PlowSite Fanatic
    from Maine
    Messages: 5,035

    Sooo, he bought just the plow, or the truck too? Jeremy is right, you (or whoever installed it) plugged into something that it shouldn't of been. Dig out the owners manual, flip to the fuse block(s) page(s), and find yourself a better source for the red accessory wire. If all else fails, seek out the cigarette lighter fuse location.
     
  4. JCByrd24

    JCByrd24 Senior Member
    from Maine
    Messages: 232

    Another possibility is system voltage getting too low. I had a similar issue with the factory battery and my Meyer, mine was just the brake system warning in the information center. It's a common problem on the gm trucks due to the computer controlled alternator not reacting quickly enough to the draw of the pump. My fix was ditching the factory battery for a die hard platinum (odyssey AGM).

    What happens on left, right and down commands?
     
    Last edited: Dec 25, 2012
  5. RepoMan207

    RepoMan207 PlowSite Fanatic
    from Maine
    Messages: 5,035

    Are you seriously comparing a meyer to a fisher multiplex system? Not to shoot a good deed down, but when you specifically don't know what your talking about (does that even make sense.?) Your good intentions can become insult to injury.
     
  6. JCByrd24

    JCByrd24 Senior Member
    from Maine
    Messages: 232

    Well you did shoot it down, very clearly and without much regard for being insulting. Squeezed it in on the last few minutes of Christmas too, nice job.

    The issue I brought up has nothing to do with brand of plow, it has to do with high current draw and the gm charging system and is a well documented issue on his particular truck. Maybe if you spent more time reading, learning, and helping people here than shooting others down you would know that. Or maybe if you had a clue about how things work you would understand what I said.

    OP any progress?
     
  7. RepoMan207

    RepoMan207 PlowSite Fanatic
    from Maine
    Messages: 5,035

    Lol...nobody told you?? I'm the resident A..hole.

    With that being said, my apologizes...I thought this was on an entirely different thread last night. In fact, I thought I had erased my post, and replaced it with "delete", after I relized it last night...That's what I get for using the mobile site while slightly inebriated.

    In regards to this...you obviously don't have clue. :rolleyes:
     
  8. chevyzrule810

    chevyzrule810 PlowSite.com Addict
    Messages: 1,239

    would this be something to do with plow side?The lights seem dimmer then normal on the plow.The other thing is all we are getting is a clicking and the motor is not doing anything not trying to spin.I always have a spare motor in the garage incase on decides to stop working.Could it be a motor issue? The other thing is the lights are peterson lights that have been spliced into a fisher harness.The lights aren't grounded. To the motor.Does that make a difference?
     
  9. 2000dodgeram

    2000dodgeram Junior Member
    Messages: 5

    My brother had the same problem, except it got worse, we have had it fixed before, but I guess not well enough. My brother was recently plowing with our plow truck, and the plow will not go up or down, so we took out the control box, is there anyway we can hardwire it, because we are supposed to get a foot of snow, so we need it tonight, please help, thanks.
     
  10. RepoMan207

    RepoMan207 PlowSite Fanatic
    from Maine
    Messages: 5,035

    Chevy: Yes, it's supposed to be grounded...black orange wire coming off the lights needs to go to the ground terminal on the plow's motor. Let me guess...the aftermarket lights that are on it don't have any extra wires.?.?
     
  11. Spool it up

    Spool it up Senior Member
    Messages: 912

    thats called spaghetti wiring . does the wiper come on when angling to the right ?:confused:
     
  12. chevyzrule810

    chevyzrule810 PlowSite.com Addict
    Messages: 1,239

    No ground wires no.My mm2 square lights have a ground running to the motor.And each turn/running light has a ground.Hooked the truck up to a known good plow and it functioned fine.Hooked the truck back up to the plow and hit the joystick and got clicking but no movement.Tapped the motor a few times with a hammer and the plow started moving.After moving the plow in all direction a few times the plow is fine and the truck isn't acting up