1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

SEHP problem

Discussion in 'Fisher Engineering Discussion' started by Flipper, Nov 1, 2007.

  1. Flipper

    Flipper PlowSite.com Addict
    from CT
    Messages: 1,180

    I am having a problem with one SEHP out front powerpack. I have a few that I service along with the insta act packs and only experience this problem with one setup.

    What happens is at any time, pow could sit for weeks or just been checked, when I check the fluid by removing the plug on top next to the motor, I get fluid spraying out. Normally the plow level is fine, well below the plug but above the pump. It only sprays out, does not run out (it is not overfilled) We have tried filling to different levels etc to no avail. Removing the plug slowly while limiting the spray still some.

    Plow operates fine, no apparent air in rams etc. Some how though the resevoir is getting pressurized. Anything I am missing? Any fixes?
  2. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Kinda had the same issue with a Western Isarmatic one time (same thing though)..and it drove me nuts for a while until I realized the sump housing had a crack in it where the pump pressure passage crosses from the gear pump, through the housing and over to the valve block.

    It would only do it when it was above about 40 deg out, as the aluminum housing would expand from the warmer temps just enough to leak pump pressure into the reservoir...wasn't enough to affect the pump pressure, but sure did a good job of pressurizing the reservoir :eek:.
    Last edited: Nov 1, 2007