1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

SEHP motor question

Discussion in 'Fisher Engineering Discussion' started by VTplow, Dec 27, 2010.

  1. VTplow

    VTplow Junior Member
    Messages: 4

    Does anyone know if you should be able to turn the SEHP motor by hand?

    The reason I ask is mine is acting like it is frozen - has 12Vdc to it, and it draws my volt gauge down on my dash, but you can tell the motor and pump are not running. When I took it off tonight it feels seized but I can't remember if you can turn the shaft manually or not?

    Jake
     
  2. sweetk30

    sweetk30 PlowSite.com Addict
    Messages: 1,588

    you can turn lots of hydro pumps by hand to kind of test. and electric motor should turn real easy and free.

    so if the motor wont spin its prob toast.

    if the hydro pump inside shaft wont spin then time for a reman / clean out job on the pump.

    lots of readin i do guys get lots of moisture in these style pumps and get sludge build up in the pump screen and then if water is in the pump and then freezes it can freeze up the pump.

    so check it all out while you got it this far torn down or pay to do it all over again payup
     
  3. VTplow

    VTplow Junior Member
    Messages: 4

    Thanks for the reply - this is what I was figuring but always best to ask ...

    Looks like the motors are pretty reasonable from what I looked up last night.

    On the pump, I can turn the shaft by hand - and I can get about 3-4 turns out of it then it feels like it is building up pressure, is this normal? Or should you be able to spin and spin and spin? If I spun it up to the point of tension then let go you can see the shaft return to position - is this actually building up pressure against the solenoid and bleeding back or am I feeling something else?

    I changed the fluid and the filter this fall but I never tested the motor - my bad!

    Jake