1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Salt Dogg SHPE 2000 Baffles

Discussion in 'SnowDogg Snow Plows' started by TheTurfdoctor, Dec 20, 2012.

  1. TheTurfdoctor

    TheTurfdoctor Junior Member
    from Maine
    Messages: 1

    I have a SHPE 2000 spreader and have been experiencing frequent auger malfunctions recently while running straight salt. The auger has been jamming up for the most part. The Baffles are currently set at 5" open on the back (closest to the motor) and 3" on the front. I am thinking the baffles are open too far which is causing too much material to jam into the canal. Any thoughts before I do trail and error.
  2. Spool it up

    Spool it up Senior Member
    Messages: 912

    I beleive their closed too much . I modded mine by flipping them with some angle iron using the same oem bolts and holes . It's more of an anti-bridging issue than a choke-flow. Hasnt jambed since and flows like a waterfall. HUGE difference.
    Last edited: Dec 20, 2012
  3. icudoucme

    icudoucme Senior Member
    Messages: 349

    Are you sure it's jamming and not getting enough?
  4. Grassman09

    Grassman09 2000 Club Member
    Messages: 2,806

    I had the rear baffle completely out and the one closed to cab 3/4 open.. Hit the vibrator and it usually frees itself. My 2.5yd i took the inverted v competently out. A few on and off with the vibrator and it flows again.
  5. Spool it up

    Spool it up Senior Member
    Messages: 912

    we run the vibrator at all times when spreading . Sometimes the material gets damp and tends to cake.
    Last edited: Dec 20, 2012