1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Salt Dogg, anyone remove splitter?

Discussion in 'Ice Management' started by cmo18, Nov 27, 2011.

  1. cmo18

    cmo18 Senior Member
    Messages: 815

    First storm went okay, had some clogging issues. I'm running 50/50 salt/sand.

    One huge problem I believe was when the spreader was loaded some larger stone was scraped up and loaded into the spreader.

    Has anyone removed the v splitter in the box? Would it help the flow of material? Or should I just open the baffles?

    2011-11-27_09-48-21_295.jpg
     
  2. Advantage

    Advantage Senior Member
    Messages: 766

    Yes, try opening the baffles. I don't know what you have them set at but I know they come from the factory closed way too much.
     
  3. BUFF

    BUFF PlowSite Fanatic
    from FR NoCo
    Messages: 7,248

    You also may want to put a screen on the hopper to keep the big chunks out too.
     
  4. KLC99

    KLC99 Senior Member
    Messages: 160

    Always removed the splitter here
     
  5. MahonLawnCare

    MahonLawnCare Senior Member
    from Ohio
    Messages: 851

    how far do you open your baffles (inches wide), i always ran bagged until this year and was wondering how many inches wide they should be open for the spreader to not be clogged and spread well
     
  6. cmo18

    cmo18 Senior Member
    Messages: 815

    I shut the front one and opened the rear one all the way. I'm running 50/50 mix and had issues last storm.

    Is there a point to the splitter?
     
  7. justgeorge

    justgeorge Senior Member
    Messages: 223

    I just bought a poly Salt Dogg HPE2000 (looks like you might have a stainless?) and it didn't have a splitter in there.
     
  8. cmo18

    cmo18 Senior Member
    Messages: 815

    No mine is poly
     
  9. G.Landscape

    G.Landscape Senior Member
    from Ontario
    Messages: 847

    We just picked up a SHPE2000 as well and there was no splitter, I don't see a use for it. We spread only treated salt and my dealer set both openings at half.
     
  10. Showmestaterida

    Showmestaterida Senior Member
    Messages: 407

    Did you buy the unit new with inverted v ? Never seen one new like this.
     
  11. cmo18

    cmo18 Senior Member
    Messages: 815

    Didnt buy it new but I was told from the previous owner it came like that. Dealer said it was to keep material from freezing up in the auger.

    Not sure if I should leave it or remove it
     
  12. Showmestaterida

    Showmestaterida Senior Member
    Messages: 407

    They arent in the new ones . I would remove it and try the baffles settings , spread, adjust baffles , Half baffles seem to work well for me, spreading 100 salt. Yes, dont let big chunks in the auger it will cause problems. They come with a topscreen for this reason . If didn't come with one, make one up. Theres pics of them on here. Well worth the time and energy to build one.
     
  13. PALSLANDSCAPING

    PALSLANDSCAPING Member
    Messages: 43

    I bought two new 3 yders last year and both of them had them in it.