1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Salt Dogg 2000 Auger Problem

Discussion in 'Ice Management' started by ohiogreenworks, Feb 16, 2010.

  1. ohiogreenworks

    ohiogreenworks Senior Member
    Messages: 381

    Here is the situation. Spreader was bought new in October 2009. It has seen a max of 25 tons of rock salt. With the baffles in the factory position, it fed alright but I was given some really bad salt so I opened up the baffles to make it easier for me to poke something down thru the screen and into the openings. Then I had problems with the auger, it wouldn't move sometimes. I thought maybe it was because of too much weight sitting on the auger with the baffles too far open. I closed them down farther than the factory setting to minimize the weight on the auger (I now am using nice clean dry salt). Today I put just around 1 ton in it. Baffles are only about an inch open. Everytime I turn on the auger, nothing happens. I have to go beat on the plastic cover on the auger motor, which I have now cracked from beating on it so hard. Once it starts, it works great but then if I turn it down or off, it won't start again without being beat. Anyone having any similar issues? Gonna take it to the dealer I got it from tomorrow or thursday and see what they say.:help:
     
  2. ohiogreenworks

    ohiogreenworks Senior Member
    Messages: 381

    Went to the dealer today and he ordered me another auger motor under warranty. We will see if it works any better once replaced.
     
  3. tuney443

    tuney443 PlowSite.com Addict
    Messages: 1,847

    Keep us tuned.I've got the 1500,not happy at all with it.Been waiting for over a month now for my new ''different'' Chinese controller to arrive.The spread pattern literally sucks--wasting lots of Magic.
     
  4. msu1510

    msu1510 Senior Member
    from MI
    Messages: 128

    i just purchsed the salt dogg 1.8 cubic yard electric stainless steel v box in dec 2009. i have been very happy with it. my dealer had the new controlers in his office. we opened the box took out the original controller and he handed me one from his office. if your dealer is making you waite for the new controller that is bull @##t. they are out there. like i said my dealer had a stack of them. well good luck i hope the new parts work.
     
  5. tuney443

    tuney443 PlowSite.com Addict
    Messages: 1,847

    What controller did you end up with--the black faced OE Chinese POS,the black faced ''different'' Chinese replacement,or the white faced pre 6/09 good American made one?
     
  6. msu1510

    msu1510 Senior Member
    from MI
    Messages: 128

    i will run out to the barn and check. i dont know what color the front is.
     
  7. msu1510

    msu1510 Senior Member
    from MI
    Messages: 128

    well not sure which "pos" i have but it has a black face with a orange stripe across the middle. but it has been working fine for us this year. much happier with this spreader than the 3 snow ex spreaders we have.
     
  8. tuney443

    tuney443 PlowSite.com Addict
    Messages: 1,847

    That then must be the ''different'' replacement one.Myself and no one else has seen it in my part of the world.
     
  9. msu1510

    msu1510 Senior Member
    from MI
    Messages: 128

    i would call a michigan dealer, or better yet make your local dealer call and get you one from michigan. they are out, there is no reason you should pay that kind of money and be jerked around like that
     
  10. tuney443

    tuney443 PlowSite.com Addict
    Messages: 1,847

    You know,I never saw that orange stripe before until you mentioned it.I noticed it this morning.So this means I don't know if you have the OEM unit,same as mine,or the ''different'' one.My take would be that Buyers would have changed something inside the box and left the outside appearance alone.I would ask your dealer though what he really gave you.As far as my dealer getting warranty parts from another dealer,it doesn't work that way unless it's authorized by Buyers.