1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

RT2 V-Plow not working - HELP

Discussion in 'Boss Plows Discussion' started by G.Landscape, Feb 27, 2013.

  1. G.Landscape

    G.Landscape Senior Member
    from Ontario
    Messages: 834

    Having issues with a Boss RT2 V-plow. While plowing today the plow stopped working so I checked the connections and the battery terminals at the plow side were loose. managed to tighten them a little and it worked for a while but was slow. Back at the shop I tightened them down good but now the plow is doing nothing. I am getting 12v at the pump but nothing happens.

    Any Ideas where to start? Pump gone bad? Relay somewhere?

    RBRONKEMA GHTFD 2000 Club Member
    Messages: 2,592

    Check the ground on the plow pump.
  3. fcbob

    fcbob Junior Member
    from none
    Messages: 6

    I had this very same problem with my boss v and it was the ground to the pump causing it.
  4. G.Landscape

    G.Landscape Senior Member
    from Ontario
    Messages: 834

    So took the pump apart the other day, turned out all the wiring inside the pump were frayed and some actually broken. New pump and it runs like new, it must have been frayed for a while because it easily runs twice as fast as it was before.

    Also fyi if you hook up the hydraic hoses backwards to the pump it caused everything to run crazy!! Wing control move plow up, up causes wings to scoop, and when lowering the plow the motor spools.