1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

RT1 Straight blade question

Discussion in 'Boss Plows Discussion' started by kpmsnow, Nov 29, 2009.

  1. kpmsnow

    kpmsnow Senior Member
    from Elkhart
    Messages: 156

    Just put the blade on and when I hit the switch to try and angle the blade left "no matter what position it is in" some times it doesn't't do anything, or it angles and raises the blade at the same time, or it works fine. Is my angle switch bad, solenoid bad, or a wiring gremlin? Any help would be greatly appreciated.
     
  2. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Wiring gremlin would be my selection. It's the only way it could raise while trying to angle. May have a bad section in the harness somewhere between the rocker box and the valve manifold. Need to go over it with a fine tooth comb.
     
  3. kpmsnow

    kpmsnow Senior Member
    from Elkhart
    Messages: 156

    Crap! I was really hoping for a hard part malfunction. Much easier to figure out!
     
  4. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    No real hard parts that can cause your issue. Not what you wanted to hear I know. Perhaps next time I'll just say it needs a wash & wax. :D
     
  5. kpmsnow

    kpmsnow Senior Member
    from Elkhart
    Messages: 156

    I would have at least felt moderately productive then lol. I appreciate the info though. Thanks. I'll start digging first thing Monday